Phantom 4 won't power up

My Phantom 4 does not power up. I get a blinking power on light then it shuts down. I tried changing batteries, and changing the SD card, no change. Do not know what other steps I may take to get it to power up. I did recently transport it to another State, it was in a DJI hard case. I can’t believe it could have gotten damaged in there, obviously something went wrong. Any idea’s?

Sorry you are having problems. I cannot offer any shortcuts for fixing it. You could risk taking it apart and looking for loose connections. A better option may be to send it out for repair. There may be a repair service near you and they should have all the required parts. I can find several in my region when I search on Google.


OK, thanks for the reply. I was afraid of that I’ll look around.

Blinking green or red? When you single-push the button does it show the charged lights, at full power?


  1. Has it worked before? When did it start?
  2. Does it happen with all batteries?
  3. Are all firmwares updated? Including the batteries.

Try to quick-click the battery at least 5 times. Sometimes this will start it up in lieu of the normal 2-click.