Phantom 4 pro just hovers

Summary of Issue:
Drone took off and just hovers 10 ft. In air. Won’t Go furthet5
Date Issue Began:
Drone Model:
Phantom 4 pro
Mobile Device Model and OS version:
Azusa tablet, Android 7
DroneDeploy App Version: latest at time

Can you try to make a copy of the plan and restart the hardware? I’ve experienced a glitchy plan occasionally and this usually worked out.

Tried a copy of the plan and even charted a new plan on a different field and still have the problem, ie drone takes off and hovers 10 ft. above ground. I have another drone, so will try that, and that might isolate if the problem is with the drone itself, or with the dronedeploy software and its compatibility with DJI products.

That sounds like a good plan. Does it do this in other places or just that plan? Sounds like maybe a GPS issue, maybe some interference there…

Hi @Glenn_Shields,

Oh no, I’m sorry to hear you were experiencing difficulties on your recent mission. Have you tried checking to make sure that all firmware on your drone and RC are up to date in DJI Go 4? I recommend restarting your drone, RC, and device completely, then calibrating your compass to see if that helps.

Please let us know if these suggestions work for you. In most cases where we see drone hovering behavior, it typically indicates a hardware issue such as GPS interference. You may want to check if this behavior persists at another location away from any metal equipment, power lines, cell towers etc.


I have the same behavior with my Mavic Pro, what fixes this is starting the motors after systems check but before pressing the start mission button, it wasn’t like this before, but I’ve learned to live with this.

Given the focusing issues the Mavic has, I’m surprised you’re not at the set mission height with Go4 before activating DD. Activating DD mid-flight is compulsory for me.

Do you shoot DNG using this method by any chance?

Just tried again to get my Phantom 4 pro to fly with Dronedeploy. Manually raised the drone about 100 ft. in the air using joysticks. Then activated drone deploy, It flew the field and returned to the starting point. But then I tried to lower the drone to the ground and it wouldn’t let me control it with joysticks, kept trying to go back to its home point. Finally got it down, but crashed it. So, not a good idea to activate drone deploy at a elevation, unless you can fool it somehow to terminate its control after taking the pictures.

Tried to use drone deploy on my Mavic pro, but it wouldn’t connect to the drone.

Things worked fine for the last 6 months until the last updates of both drone deploy and DJIGo. So suspect a bug between the firmware, DJI go and Dronedeploy somewhere.

Any idea where to go to here? Any other company with a better mapping/flying software that works better.


1 Like

How strange. I flew my Mavic on Monday and Wednesday of this week with what was up-to-date firmware/software at the time without problems. Up with Go4 to elevation, switch to DD, do what it needs to do and then either RTH manually or allowed it to come back on its own to land where Go4 took off from.

That said, woke this morning to an auto-update of Go4 so maybe things will head south for me. I do hope not because I’ve only just got it straight.

Edit:- it was my Android device that updated to Go4 v4.2.12 last night but my iOS remains on the same version updated 2 weeks ago with no updates available.

DD is on v2.71.0 on both Android and iOS with no available updates for neither.

Flew twice this week with up-to-date firmware and software and no problems. I do worry what problems might be on their way.

The other thing, do we not just flip the switch on our controllers to regain manual control of the drone?

James, didn’t understand your last post. What switch can you flip on your drone to regain control from dronedeploy? Can you just shut dronedeploy app down?


Hi Glenn.

To use DD, the switch on both the P4 and Mavic controllers must be in P mode but if for any reason you need to take manual control of the drone again, move the switch to S mode. DD will remain active on your display but the controller will kill communication with it leaving you with standard stick controls again. It’s like a safety switch although I have not yet had to use it.


Tried to use Dronedeploy to fly field yesterday, after an update from Dronedeploy. Also recalibrated compass on Phantom 4 pro. dronedeploy still won’t start, takes off and hovers about 15 ft. in the air. So, shut drone deploy down, manually launched drone with joysticks to about 30 ft height. Then launched dronedeploy and it completed the map. When landing, I took control of drone with joysticks as it approached ground. This time, dronedeploy let me control drone with joysticks, so it didn’t crash as before when dronedeploy wouldn’t let you control drone manually. So, still not sure what is going on. Thanks for the advice to switch to atti mode, in the future if drone deploy tries to crash my drone, I will know what to do.


1 Like

I had this happen and I think it was the obstacle avoidance sensing the open tailgate on my truck. After a couple of tries, I moved the takeoff point a few feet further away from the truck and it worked fine.

1 Like

Hi @Glenn_Shields,

I think @HawkViewAerial is on to something. When the drone is to close to an object, and object avoidance is turned on, it will hesitate until it has sensed that the flight trajectory is clear. Always make sure to keep an eye on the drone while it is in flight so you can take over manual control if need be.

1 Like

thanks for the input but it did go up 387 feet first and then wouldn’t go to the start point on the map. I think I have it fixed. I refreshed the firmware this afternoon and I did a little test and it seemed to be working. I have full day tomorrow I hope it fixed it. Thanks everyone.


Refreshing the dji firmware seemed to work. No more tomorrow.