Need advice on a DroneDeploy glitch

Hey gang, need some input on a DroneDeploy anomaly I ran into. I’m flying a Phantom 4 Pro V.2, less than a year old. Today’s flight was brilliantly sunny skies, low wind, warm-ish temps. An ideal flying day except for one aspect, which was a KP index of 4, which I’m learning is a risky level to fly at. Don’t know if that factored in, not real educated about the KP index. So I have a mapping mission that I’ve been flying for a year and I tried to fly it today. The drone would take off, fly to it’s beginning point, then begin flying the route and snapping pictures, but today the drone would only fly a couple of feet forward and would only snap about two pictures, then it would stop and hover. I would bring it down, relaunch, same issue. I even went so far as to delete DroneDeploy from my controller and reinstall it. I flipped between manual and autonomous control a few times hoping to “shake it loose”, I would force the drone backwards a bit and let it restart, I would fly the drone too far forward and let it restart. In all scenarios the drone would fly to where it last left off then just stop and hover. Anyone seen this before? Can this be a KP index issue? My understanding is that KP index affects the GPS but this feels like something different. Oh, there were 16+ satellites too, so that was as expected. I’ve looked through the 4 logs from DroneDeploy (entered into Airdata) but I can find nothing useful there. And unfortunately after I moved on to other manual flight segments, some other problem cropped up and the drone was lost, so I can’t get logs out of the drone. I am just hoping to learn about this “stop and hover” thing so I can combat it in the future.


Yeah, there’s a couple of other threads on here about the same thing so as it becomes more common and people work with DroneDeploy support the easier it will become easier to figure out fix. I have seen reports of similar issues when trying to initiate panos.

Oh, lovely. Well, thanks for the info!

Have you tried turning off obstacle avoidance?

Had the same thing happen to me several months back, turning obstacle avoidance off fixed it for me.

Actually I can’t remember if obstacle avoidance was on or off when the problem happened. I flew again today with obstacle avoidance off and the same thing happened, just flies forward snapping pics for a short while then stops and hovers. I’ve since learned there others who have reported this and it’s a bug that needs to be addressed by DroneDeploy. My fix today was to pull the drone down, drive to a different spot where the drone would start at a point opposite of where I was trying to launch from, and this did the trick. Going in the opposite direction let it keep flying until the end. No idea why it suddenly cares which direction it starts traveling in.

No such luck for me anejojoe. Definitely had it off today, problem still happened.

@paulpoperocks Can you share your DroneDeploy app version and platform (iOS/Android). To fully look into this a message into is your best bet. Cheers!

Andrew, I don’t have that info at my fingertips right this second, but I think an answer has been found on another forum. I was flying into a low, bright sun, not realizing this is an issue. I did the same thing today and the flight still stopped and hovered, but then I changed the route so it started flying away from the sun and it continued and finished the flight as normal. I do believe this was the problem.

@paulpoperocks In that circumstance I would expect the drone should only be bothered in flight path if obstacle avoidance is mistakenly triggered by the sunlight. Interesting that you had disabled obstacle avoidance and still encountered the issue.

That’s actually a good point. I’ve had a drone stop in DD for no apparent reason, and then I figured out that it was stopping due to sun glare and the drone thought there was an obstacle. Turned off obstacle avoidance seeing as the area was clear of hazards and it flew with no issues.

1 Like

Had this happen many times before I figured out that my take off point was too close to plants/objects - obstacle avoidance.

1 Like