Phantom 4 - Mission Start - Climbs to max height and hovers

Hello all, long time listener, first time caller :wink:

I’ll get straight into it.
I’ve attempted 6 missions with DroneDeploy with no success. Read the previous posts that have similar but not the same issues so hence my new Topic!

The planned mission starts, Drone takes off and heads towards start waypoint, that’s about as far as I get. On transit to Starting waypoint the Drone (Phantom 4) then climbs above mission height (tried multiple missions including a very basic “stock” mission) to max legal altitude (400ft) and hovers…

After my latest firmware “reflash” the drone got to the starting waypoint and set off on the first leg and started image capture but never got further than a few meters past the starting waypoint before I had to RTH (altitude).

Hardware info;

App - Version 4.0.8
Aircraft - Version 01.02.0602
Remote Controller - Version 1.8.0
App Database - Version

iPad Mini 4
Version - 10.3.1

Any assistance would be appreciated.

I can’t downgrade the firmware, I’ve only managed to re-flash via the DJI Assistant 2 Software for PC.


Hey. If you can private message me we’d love to get the logs off of your drone so we can forward these to DJI to figure out what is happening.

Having the same issue Chase,
Would be great if you let us all know what response you get from DJI. I am running almost with the same settings of Nitram. Except that i have an ipad mini2 and that i was succesfull in creating several maps before this issue emerged. Also tried to fly with Maps made easy and had the exact same issue, which tells me that is an issue with DJI.


I’ve forwarded some useful logs to DJI. Will let you know.


Hi chase,

Any updates from DJI on this one?

Just wondering if you received any updates?
Encountering the same issue currently.

Various maps and missions were completed prior to issue arising.

Using: DJI Phantom 4 Pro

Hi @JSt.John,

Is your DroneDeploy app version currently 2.61.0?

Keep me posted,

Hi @Christina ,
We are running Version
We have also made sure DJI Go was not set as the default option with the USB

Hi @JSt.John,

Can you share the email address associated with your DroneDeploy account as well as the name of the map(s) you’ve experienced this issue with?


Hi @Christina ,

The E-mail address associated is
the maps where this issue occurred are titled “Hoople Bay South” and “Woodlands Island”

( with both missions the UAV would climb to the maximum height set - above mission height- and hover. Manual control remained working, as well as the Go Home function. )


Thanks @JSt.John. I shared the info with my team for investigation. I’ll report back once I have info to share.

Hi @JSt.John,

I wanted to share an update and let you know that my team is aware of the issue and are investigating, but there is not a timeline to share of when the issue will be resolved.


Hi @Christina

Thank you for the update. Your and your team’s efforts are greatly appreciated!

We’re trying our best! We also understand how frustrating it can be when issues aren’t resolved as soon as possible, but we do appreciate your patience and cooperation - especially during the holidays.

Do you think it could be strong winds setting off the OA sensors and causing it to climb?
We have run somewhat successful flight plans but not without multiple occurrences of the issue.

Hm, do you notice that this issue frequently occurs when there are strong winds, @JSt.John? Does the issue disappear when there are mild conditions?

We have abandoned the O.A sensor theory.
I have since found out that the firmware was not consistent across the RC and UAV and have downloaded the latest for each, creating consistency across devices. I have read this could be our issue and we are hoping this was the simple fix!
Thanks again!

I have my fingers crossed for you!

Hi @JSt.John,

I wanted to follow up and see if you’re still experiencing this issue.

Let me know,