Drone just hovers, not moving

#1

Hello everybody,

We are struggling the past 5 days with a phantom 4 pro v2 with the following very strange issue using dronedeploy

While using dronedeploy we set up a relatively simple mission (a simple square about 1hec).

We tried the following:

  1. Mission in dense city, trying to take off a rooftop (takeoff point located in the mission area)

Drone is connected to remote and the app. Mission is loaded. Drone takes off about 3m of the ground and doesn’t move from there. We tried any possible combinations such as changing the attitude, changing the shape of the mission, moving the mission to the next block away from takeoff point, toggling on or off obstacle avoidance and other settings, changing overlap. NO LUCK. After many tries with both apps we either had the behavior described above or got an error message: “Flight Plan. Error loading waypoints. The execution could not be executed”

  1. Mission in dense city, trying to take off 250m away from the mission, on a very small park between roads (takeoff point located outside the mission area)

The mission is loaded and drone flies as expected. Isn’t that strange?

  1. Mission in a football court, trying to take off from the middle of the court.

The mission is loaded and drone flies as expected.

The No 1 configuration was tried over multiple different blocks in the city and we had exactly the same behaviour meaning the drone was hovering without starting the mission.

It could be an sdk error or a limitation when flying in dense city areas?

We are surveyors - engineers and we are really disappointed and have already wasted dozens of hours trying to survey blocks in the city.

Any help would be really appreciated.

PS: We have tried all of the above both in android and ios (iphone 8) devices with exactly the same behaviour.

#2

On the problematic missions, are you able to launch and fly using G04 ?

#3

The error you describe typically comes up if you are using structures mode. Turn it off.

I’m assuming you are not trying to fly in a geofenced zone?

#4

If you are using any kind of landing gear that attaches to the bottom of the legs it is probably blocking the sensors and causing the drone to act strangely. Also, try the flight with obstacle avoidance sensors set to OFF, at least for testing. May have to fly with this setting off depending on area and such. Good idea to redo compass calibration before flight in that specific area too. Good luck.