Phantom 4 is Not Start mission,Stay hovering

I’ve seen some similar questions, but I can’t solve the problem so please let me know.
When you start a mission with the Drone Deploy app, the drone will not move from the starting point and stayed hovering.
Done:Phantom 4 Pro v2
Device:i Pad mini5
each SW ver.:latest
It used to work fine, but now it often has this hovering issue.

I tried following,
-Chack DroneDeploy’s trouble shooting
Canceling beginner mode,switch P mode,check max flight altitude and distance settings,check NFZ,etc.Thise are no problem.
-Calibration of IMU
I haven’t done the compass yet, but it is displayed in a normal state on DJI GO 4.
-Check other Apps
GS PRO is no problem about mission start.
But today,I can’t also solved this issue.
Is there anything else I need to check?
And what is the cause of this symptom in the first place?

It would be helpful if someone could teach me.

1 Like

Have encountered similar, can be frustrating, what found as a work around, land the aircraft. Power the aircraft down, shutdown the app, shutdown the controller. Make sure no other apps running on your device, also check your GPS coverage and wx conditions. Power up controller and launch DD app, select your mission, power up aircraft, wait until you get good GPS sync etc. Start your mission preflight, once it is ready to launch, wait a few moments, then press green to go. IF your aircraft goes up a short distance and continues to hover, see if you can manually get it to go up or not. Also, make sure that your switch selector is set to P and not ATTI mode, have found that if in ATTI mode, strange things occur.

Hi @Harakiri, we would love to help. Could you please message into support@dronedeploy.com for troubleshooting? Happy flying.

I recently had some bizarre problems with mine. The controller said it had exceeded the allowed altitude and wouldn’t take off. Sometimes it does weird things (error messages) if the SD card is too slow.

1 Like

I didn’t notice this thread as I found out via google several threads that state the same issue, I posted in another one but I copy my issue (same as OP) here too, you can disregard the other message or maybe close that other thread and keep this one???

Well here it goes;

It seems the problem has not gone away for a while and it’s a problem coming back from since at least 2018 as I’ve found several threads discussing the same with no apparent reason for the problem which leads to no apparent solution, I post my experience of the past 2 weeks here;

  • I am mixing two application to execute my missions, one of them is DroneDeploy the other one is 3DSurvey, I flew a couple of missions with both apps with no problems at all, then after 3 flights more or less problems started.

  • I’m flying a DJI P4P V2.0 with a Motorola G8 Power with Android 11 up to date. Firmware of both devices (drone + phone) are up to date. Software on the phone is up to date.

  • My flying pipeline (For DroneDeploy and 3DSurvey app) is;

    1. Turn on drone. Turn on drone's RC. Wait for them to pair.
    2. Phone in airplane mode. Connect drone's RC to phone with cable.
    3. Wait for phone to offer me an app to open the connected device.
    4. Open DJI GO 4 app and do a recon flight to configure camera settings and check altitude and possible obstacles in the path.
    5. Land drone and close the DJI GO 4 app. Make sure it actually closes via showing the list of opened apps and closing it. (see the end of my post for update)
    6. Open DroneDeploy and search for the mission to execute. Check the settings are correct and start pre flight checks.
    7. Once checks are passed, start the mission.
    
  • I experienced the hovering problem with both applications, a restart of phone and drone used to fix the problem and then I could execute the missions.

  • I started generating more polygons and made available offline the projects so I could execute the missions despite the poor 3G coverage we have in the area, I saved all the information in the office to then execute missions on the field.

  • The hovering problem got more common and then a restart of the systems (phone + drone) didn’t fix it at the first try and had to do more than once.

  • As for the next mission this got even worse and after several restarts and trying it finally goes for the mission, but this has lead to loose at least 30 minutes trying to figure out what the problem is, restarting the systems, and trying to launch again, even in the process I’ve recreated the missions from the scratch as I already have the polygons in my mobile, just import polygon, configure settings, launch mission.

  • What I’ve experienced is pretty much the same documented in this thread and in several others; The app does the check-ups, sends the mission to the drone, drone starts systems and starts the flight, hovers around 2-3 meters above ground and stays there, indefinitely, until you take control, cancel the mission, or force the landing.

  • I’ve tried changing settings to the missions, polygon sizes, flying speed and others, same issue most of the time, it seems that at some point, randomly, the app decides it will execute mission and then it does.

  • Yesterday a problem that worried the most wast that the DroneDeploy app showed a poor connection message and then a lost connection between drone and the app. At this point I thought it could be the usb cable between the RC and the phone the problem (???).

Update mentioned above;

  • At night I kept thinking about this issue and then while messing with the phone (not connected to the RC or the drone) I found out that the DJI App, the Drone Deploy App, they 3DSurvey app are still running in the background of the phone despite exiting from them and closing them from the showing list of recent opened apps. I found about this because when you keep your finger on the icon of the app “App Info” bubble shows which leads you to the settings of the app and there you can force stop them. Maybe it’s related to this???

I’m keen to your experiences and comments on this!

Cheers.