Phantom 3 Advance

Would just like to know when will the P3A be compatible with dronedeploy?

Actually trying to release this in the next couple of weeks.

Looks like the Phantom 3 Advance works with the newest version we released with the latest dev firmware. Going to update that post with the Phantom 3 Advance firmware.

The only problem I saw was our image counts are incorrect because we need to adjust how we obtain those.

Hi There,

I updated my P3A to v1.04 but i cant get dronedeploy to work. It goes through all of the checks except for mission and camera.

After a while it displays the message at the bottom that i should refresh the page or contact support. Iam using the Beta app form the app store.

I’ve installed the beta 1.04 and app 1.1 in my P3A.
The aircraft’s update was ok, but the remote no. I tried with pendrive directly and with a usb cable connected to camera. No file created nor in pendrive or mini SD. The light don´t blink. But with DJI Go app works fine.
In the Drone Deploy app, all the checks are ok, but it don’t initialize mission.
I made a screenshot but don’t know how attach.
The error message is “Take off failed. Check drone and controller”.
Any help?

I think this forum disables screenshots for users before they post a few posts. You can send us info at

Hi Deneys,

I looked at your logs and it seems you are missing an SD card. The advance support we have is still early so checks like that seem to be broken.

Hi there,

I will give it a couple of more tries today. The SD card was in, and working as i took a photo with the DJI app. I can remember it had the same problem with the first version i tried (one that was for the P3 Professional). I will keep testing and let you know what it does

I gave it a try. Made sure the camera takes photos in the DJI app and then closed the DJI app and force closed in task manager. Then opened dronedeploy. All checks go quickly and then it gets stuck at camera and mission, I left it for about 7min. But nothing happens.

I’m not sure what is wrong. We have some other users flying with the advance. If it gets stuck at camera and mission then it is trying to take a test photo. I’m not sure why is tells us that there is an SD card error.

What would you suggest? Uninstall and reinstall everything?

I tried it on 2 different devices Note3 and galaxy S5, both not working. The only weird thing that i am picking up is when i go into DD and then force close the app and go in the DJI app without restarting the drone and controller, the DJI app does not pick up my drone at all. Just displays disconnected at the top. Almost like the link between phone and controller is hanging. I see that the firmware i have installed is 1.04 0004 and on the DJI site there is a 1.04 0005. I will install that and let you know if it works.

I would try the upgrade. If there wasn’t an upgrade I was going to suggest a downgrade then upgrade again.

Still not working :frowning: did the update to 1.04 0005. As soon as the msg apears on the bottom of the screen. “Deneysvd_inspire1 a problem… refresh the page or contact chat” then nothing works

Update: I have now reverted to 1.04 0001 and tried diffrent SD cards. Recalibrated IMU and gimbal in the DJI app. Formated The SD card. Uninstalled DD and reinstalled. And got it to work :smile:

For some reasn it only works if the SD card is formated. If it has any folders or files on it, it does not work.

So have you found that it was definitely the folders and files on the sd card? We’re they files from non phantom 3 things?

No, they are only phantom 3 things. If i try and do a second mession without deteling everything on the SD card the camera and mission checks does not go green.

How do I revert to a previously firmware?
Is there a documentation about this?

For the aircraft you should be able to just do it the same way you upgraded. Have you tried that yet?

Last reply here was on Sept 2015,

Now, with the new beta released, I read it is for I1 and P3pro only and advanced will not work.
As I won’t be risking my P3A for this, appreciated if someone could tell me if that is true, p3a is not supported on this app.


Advanced has been working for several months now.