New Releases: iOS app support for Phantom 4 Pro and Inspire 2


#1

Have an Inspire 2 or Phantom 4 Pro drone? Now you can fly it from your iOS device using DroneDeploy! Just make sure you’re on the latest version of the app.

Please note that DroneDeploy does not currently support the Phantom 4 Pro Plus drone (with the controller that has a built-in screen).

If you run into any issues or have any feedback, please let us know!


#2

How are the field results versus the P4/Inspire 1’s? Excited to give it a try.


#3

I’ll be sure to try it today and let you know!


#4

Should this update work with the lates Phantom 4 Pro update that was released yesterday?


#5

It is working with the Phantom 4 Pro on the latest update. One thing I noticed with the camera auto settings is that , it’s white balance setting is off which in turn makes my images have a blue hue . I switched it to manual settings and it fixed the issue.


#6

Thanks for sharing - Can you share the image with auto settings? What manual settings did you use?


#7

Any word on when the Android version might arrive?


#8

I sent you an email just now!


#9

Not yet, but they’re working on it as it’s a top priority.


#10

+1 for the Android version.


Camera control Inspire 2
#11

I’m having the same issue with the Blue-ish hue when using the auto settings. I’ve done testing with the Phantom 4 Pro and the Phantom 3 and have seen similar issues with both. Currently flying in areas with snow on the ground, but typically I don’t have issues with it. If set to manual conditions, it seems to work.


#12

I’m having issues with the Phantom 4 Pro starting to take photos at the beginning of the mission. It is very inconsistent. When you get to the start point it should say “photo capture started” I’ve gotten it to work a couple times, but most of the time it doesn’t work. I’ve tried restarting controller/app/drone and it didn’t help. Also tried switching to a different iOS device – same problems.

If I use the P3 Pro it typically works. However, during my testing today, I had two separate flights with the P3 where the controller/drone lost connection during flight. No line-of-sight or obstruction issues. I haven’t had this happen in about 6 months while using DroneDeploy


#13

My phantom 4 pro starts taken pictures in the mission start point just fine. Where I have the problem is in the auto settings . For some reason it puts the white balance setting down causing it to have a blue hue. To fix this I use manual settings on and just change the white balance setting to auto. It works just fine.

I never had the issues with my phantom 3 pro and I used to run it about 3-4 times a week for months. No connection issuses either.


#14

Sorry to hear this. Will add it to feedback to share with the team so they’re aware. Thank you for sharing.


#15

The issue of the blue hue has been solved with the latest update to the Drone Deploy app.


#16

Does DD put a change log somewhere so we can visit it and see what’s fixed?


#17

Not sure, but at least on this update they were descriptive under “What’s New” in the app.

And it works GREAT with my Phantom 4 Pro!


#18

Checking on this and will get back to you as soon as I have an answer.


#19

Did some more testing today with the P4P. I’ve updated with the app update (Jan 17) that fixed the white balance issue and I’ve made sure that I have the latest firmwarre updates for the drone and remote control. First two missions went great with auto settings for imagery.

Changed battery and flew again. Started mission, but drone didn’t start taking photos. Flew about 100 feet, then just stopped and hovered. Had to cancel mission by clicking “home” button.

I landed and started over with a new mission. Before it got to the starting point, I noticed that the white balance was “blue” again. It was late in the day, on a cloudy day and I think it seems like it sets the white balance while the camera is still looking at the horizon, then points the gimbal downward. I started over again.

This time I manually set the camera settings in the DJI Go app (took off around 200 feet, look down to get the right setttings). Then I re-flew the mission. This time it worked great.

In the past, I’ve had good luck with DD being consistent. We are looking to scale drone operations at our organization and the inconsistency in operations is going to cause concerns problems for our new users. Any help or advice you have would be greatly appreciated.


#20

I did a small test mission flying at 200 feet with my P4P. DD flew the mission fine, but no pictures were taken and the battery level was showing 0 from the start even though the battery was fully charged (confirmed on DJI Go app and battery lights). the drone stopped and hovered at around 20 feet while landing. I had to manually land the drone from 20 feet. I checked to make sure camera was working by flying with DJI Go app and took some pictures after the DD test flight.