Near No Fly Zone

#1

Recently tried to do a Job, Survey.

Got the following message " Near No Fly Zone" not actually in it but near it. Would not allow me to take off. Had to switch to PIX4d ( all OK)

Using Phantom 4 Pro

Anyone else had and issue ?

#3

Hi @Keith_s,

Thanks for swinging by the DroneDeploy Forum. Please take a look at our Restricted Areas/No Fly Zones support documentation for more information on flying your drone using the DroneDeploy app in a restricted area.

I hope this clarifies this behavior. Have a great day!

Best,
Andrea

#4

Hi @Andrea Pix4D uses the same SDK that DD uses. So you may want to reconsider your answer. Those of us that hang around here understand what we have learned at the link you provided. However, if the SDK does not currently allow waypoint missions in a DJI NFZ then Pix4D’s app would be limited in the same way as DD, correct?

#5

This is the second time I have had to survey this particular location, the first time went fine. Agree it is linked to the DJI app, However as mentioned the pix4 app worked fine. The DJI zone is not actually restricted, just an advisory. This cover a large part of the SW of England so effectively makes your product useless. Surely you only need to read the definite NO FLY ZONE unless unlocked in the DJI app via approval. no%20fly

Is there a timescale for fixing this bug

#7

Hi @Keith_s,

I have enabled the NFZ permission on your account. That being said, you should be able to attempt flying your drone with DroneDeploy in a restricted area, but please note that we do not guarantee that you could successfully fly your mission in some restricted areas. However, we do encourage you to give that a try if you have the permission unlocked from the DJI side and see if that helps.

@Dave, if you have flown a flight plan with Pix4D successfully and you are unable to fly the same flight plan using the DroneDeploy app, we will appreciate if you can share with us the name of the flight plan in question so that we can further investigate.

Happy flying!
Andrea

#8

Hi,

It is called Blackhill Quarry Lagoon

#9

Hi,

The problem seems to be that DroneDeply is picking up on the UK Yeovil air station advisory it is not restricted at all just fly with caution as there maybe low flying military aircraft. The other thing to be aware of is that the UK is going to 400ft max and allowed to fly within 1km of an airfield.

#10

Hi

Sorry see attached flight location, this does not fall under any UK No Fly Zone and is class G airspace. Also flight planned at 60m

#11

Hi @Andrea. My comment about Pix4D was in regard to @Keith_s experience that started this thread. I use DD and Map Pilot control apps, not Pix4D capture. Hopefully you enabling what you can will sort his issue.

#12

Sorry still no go, still says NEAR NO FLY ZONE.

Thanks for you help, will just have to switch to the other one.

#14

Hi @Keith_s,

Thanks for providing this information. By looking at the information of the flight plan provided, it seems that probably the issue here is that the version of your DroneDeploy mobile app is not up to date.

At your convenience, can you please can you please uninstall and re-install the DroneDeploy app to ensure that you are using the latest iteration of our flight app. Also, please make sure that you are using of the
Supported Devices (Mobile and Tablet) to improve your flight experience.

Additionally, if you receive the NEAR NO FLY ZONE message, please note that there is a button that says “continue anyway” that should allow you to continue your mission.

I hope this helps to fly your site near the no-fly zone area.

Happy flying!
Andrea

#15

I have received this and clicked through and was successful. I have also been in a dji red zone and got the same message, I think, but was not able to launch the mission. But if he is in anything less than red, I would think it should work.

1 Like
#16

Great info on this thread thanks a lot.

#17

There is no additional button to bypass

#18

Andrea … Is there a new help page? Link goes 404.

Thx
dcinHSV

1 Like