Drone started mapping then locked up

Second time at clients site, had FAA authorization, DJI geo fence unlocked.
Started the flight and the drone climbed to 200 feet, flew to where it started, shot three pictures and the drone locked up. Would not RTH with DD software RTH had to use controllers RTH.
Shut everything down, restarted and launched again, same thing, this time took five pictures and locked up.
Moved to new location on site, then it wouldn’t launch at all.
Switched to DJI and drone flew perfectly, flew the entire site manually with no problems.
Started DD again, then wouldn’t wouldn’t launch.

I just may have lost a client due to your software.
Richard Perry
Multivista San Francisco

What class was the zone? I have had trouble with DroneDeploy in the past in a specific location that had some strange zones besides the main Class C.

It is a class C airspace that is a no fly zone. Had LAANC approval for 200 feet.
I’m flying the Inspire 2.

Does it happen at other locations? Do you have another Class C that you have flown? I know that DJI Self-Unlock is a little quirky with the P4Pv2 but it might be something related to the Inspire. Have you emailed support yet? I wish they were on here more but that is the quickest way to get a ticket started.

I also tried downloading my flight data to Airdata and it didn’t show the flights.

I had another flight that same day in another restricted airspace that I had approval for. This wasn’t a mapping though, and it flew just fine.

There are other issues with DD and the Inspire 2, mainly gimbal control, but I can deal with those issues.

I’ve been doing a lot of mapping lately and normally DD has worked perfectly, but twice no in the same location is just won’t fly.

I’ll contact DD on Monday.


I’ve had similar issues with a Phantom 4 pro V2 and it actually turned out to be an “obstacle avoidance” issue - with the feature turned on, it seems at some point the optical sensors got dirty (I’m mainly mapping agricultural plots and it’s very dusty) and this happens to trigger as “obstacle” thus the drone freezes. If your rth altitude is the same (or lower) than your map plan, it still assumes there’s an obstacle and doesn’t want to move… I’ve noticed this, because when I switch to manual override (on the controller) I can move the drone, but once I start the autonomy flight it freezes (or starts, takes 2-3 photos and freezes)

Once I turned the obstacle avoidance off, I haven’t experienced these problems anymore.