Multi Battery Issue


#1

On a multi-battery mission yesterday, the app was a little buggy.

On first battery, the drone returned to home without issue. I replaced the battery, started the drone and manually flew to mission altitude. Started DD and it detected the drone and a pop-up opened asking did I want to resume. I clicked Yes and the dialog went away and the telemetry screen loaded on the left like normal but the drone just hovered in place. I shut down DD and repeated with the same results as the first time.

I closed DD again, restarted it, ignored the notification and just went to the mission in my list and started it as if I was starting from the beginning. The mission loaded and the drone started at the abandonment point of the 1st battery.

So, it ended up working but not the way it was supposed to.

P4P on ios using DD 2.7.1.0


#2

I think the step that was missed that got everything out of step was that you are to start the DD app after battery replacement. You need to start the mission from the ground and resume your flight from the ground. Doe not fly back to where you stopped taking data and then activate DD.

You should make sure that the drone is ready to take off (computer, NAV, etc) and then let DD take over from there.

Scott


#3

Hi Scott.

The app’s logic didn’t work in this case. If it displays a notice “do you want to resume the mission” (or something similar) and you click on yes, my logic is that is should indeed resume the mission, no?

The abandonment point and the remainder of the mission was indeed saved correctly, the app just fell down and couldn’t connect the dots. A clear fail.

No word from DD, so I suspect they are hard at work fixing it,haha. Doubtful.

I always launch and land manually with every app, autonomous flight plan or not.


#4

I’ll have to try this. I start DD missions from the air all the time, but have never tried a multi-battery.


#5

The more data points the better. Note that for a test, you don’t need to use multiple batteries. You are just testing the ability of the app to abandon and re-engage a mission. The number of batteries should be irrelevant.


#6

Well, if that’s the case then mine works fine. On projects less than 40 acres I have been able to fly the map, a progress plan and switch to Litchi for a video. Closing and reopening the apps each time. When I close the map plan and open the progress plan it ALWAYS asks me if I would like to resume the map because I never landed. I cancel it and select the progress plan. I have also had instances where I fly a map and an the structure mode plan for buildings.


#7

Did you power cycle between, or just switch apps? For a true test, you would need to power-cycle.


#8

Just switched apps. I haven’t had any multi-battery problems yet so I will keep my flight workflows in check and my fingers crossed. It seems like there have been several complaints since the new multi-battery interface came out. Maybe it’s just due to there being more users.


#9

It worked correctly in a previous version. TBC, I got it to work in this case, but not the way that DD intends.

New features and functions are fine. But I would prefer to have a rock-solid app instead. Have I stated that before? DJI’s model is to push out new stuff with little to no testing. I hope DD is not following that model. I suggest they drop back and follow Litchi’s lead.

Is DD on holiday?