Multi Battery Flights Not Continuing

Our company uses several different UAVs. We do not seem to have any issues with the newer drones that have DD installed directly on the smart controller. We are having problems with all of our older drones. When the drone returns for a battery change mid-mission we cannot get the flight to continue that mission. We are having this issue on our air2s and P4Pros. This was not previously an issue. Restarting the app or even restarting everything does not seem to correct the issue. Currently, we have no idea how to correct this issue. All are using the most current software for each UAV type.


Just curious because I am having similar problems on our P4Ps…
Does the mission automatically restart from the beginning or does it force you to restart it?
Are you pausing the mission in app or are you switching to manual flight to change the battery?
I flew a mission yesterday with at least 8 battery changes and while it continued the mission, it would backtrack by a significant amount after each battery change.
Let me know if you find or hear a solution!


On the P4P you have to go to the menu on the top right in the DJI app and hit continue mission. Or at least that was the way it worked for me the last time. Drone Deploy never worked right on ours.

1 Like

I’m having the same issue with a DJI air…after swapping the battery I click continue and it then gets an execution error and wont start.

There is also now no pause button…all I can do is hit RTH, let it land and then turn it off…???

1 Like

Unfortunately I don’t have a solution, but recently have been having an issue after replacing a battery and continuing the flight where after the last turn, the drone starts to head home, but stops taking pictures. I haven’t been able to post process the photos because of the missing pictures. Anyone else had this issue and resolved it? I can’t find information about this anywhere. I also am using the P4Pro.

1 Like