Mavic Air Compatibility with DroneDeploy

#124

Hi there,

  1. I’m having the exact same issue. It’s driving me nuts. I cannot find multiple flight modes option in DJIGO4 app.

  2. I am flying Mavic Air with the latest firmware.

  3. I keep getting the message in Drone Deploy saying “wrong controller mode, ensure multiple flight modes in DJIGO app”.

  4. The switch on the controller is in to the left, in P mode and still I’ve been getting this message for a month and connot use drone deploy.

Can someone please help I need to get mapping for my degree! I never used to have this problem in September 2018, but now the issue is persistent. What’s going on Drone Deploy please help!

1 Like

#125

Have you guys tried another control app?
Pix4d Capture - ios/android - free
Map Pilot - ios - paid.

0 Likes

#127

While Christina is no longer on the forum I can tell you that because of the crippled GPS coordinate accuracy the Spark is most likely not a candidate. There have been several threads here and in other forums explaining the issue with the latitudes and longitudes being rounded to the nearest second.

0 Likes

#128

I would like to be able to use a simple app that allows me to create an equally spaced grid, easily, that calculates the required number of photos and overlap to produce a use able map. Litchi does not do this, you have to manually create each way point and there is no way of creating a neat grid. Pix4d does not seem to be compatible with my mobile phone. I am usi g a huawei p smart.

0 Likes

#129

Hi there doesnt anyone have an answer? I have contacted DJI about the flight mode issue and they have just fobbed me off. Shame seeing as I gave them over £1000 for a product that I cannot use. Is anyone looking into this multiple. Flight mode issue? As soon as it was mentioned highe up. In this thread everyone seems to have dodged the question… I’m so desperate to. Get this fixed otherwise I will. Be selling the Mavic Air as itmight as well be a doorstop.

0 Likes

#130

I’ve also tried Pix4d capture and that doesn’t work. With the air

0 Likes

#131

?

0 Likes

#132

@Mark_Vickers Mark, I’m sorry for your troubles. But to be honest, the Mavic Air is one of the least desirable craft to use for mapping. If that was your main goal in purchasing it, you kind of messed up. You could have gotten the best current platform for nearly the same cost. I hope you find a solution that works for your Air. But if you are serious about mapping then it’s probably best you sell the Air and get a more appropriate tool.

Good Luck!

1 Like

#133

Thanks for your reply. I thought I had indeed messed up. I chose the air for portability. But as you say its simply not man enough for the job. I’ve just bought the Mavic Pro, as I originally intended. Would you say this is more suitable from your experience?

Best wishes,

Mark

0 Likes

#134

The P4P/P4A is the currently the best tool because of the 20mp sensor and mechanical shutter. The Mavic Pro will work better than the Air.

1 Like

#135

Have you potentially found a solution to the error? The options may have changed since the latest firmware update. Maybe DD app is looking for a setting that no longer exists. I would really like to use DD for my inspections, but I really don’t want to have to buy a different drone. I purchased the Air specifically because the DD specs stated that it is compatible.

0 Likes

My Experience with Mavic Air
#137

same problem here (Mavic Air) with DD giving me message re controller when I try to fly route. Pissing me off. I’m in NZ fwiw.

0 Likes

#138

Hi guys. Not sure if it helps. But I wrote a post with my first experience with DD and Mavic Air. Everything worked fine. Probably you did but, have you updated firmware of MA and the remote? Have you tried resetting MA to factory settings.
This is my post

1 Like

#139

Thanks @glaso. That’s what this community is about!

0 Likes

#140

Same issue here. I thought it was a compatibility issue with the new Samsung Note 8 phone that I had gotten, because I had no problems prior to getting a new phone. It must have been a coincidence with timing though. Now when I try to fly with the mavic air and my Note 8 I get the same controller issue that everybody else is getting. However if I go back to my older entry-level phone with probably a previous version of Drone Deploy, the Mavic Air flys.

So it’s not the mavic air firmware itself. It must be the Drone deploy app version in combination with the mavic air firmware, perhaps… in my humble opinion. I will check and see which DD version i have on my old phone and I’ll report back.

0 Likes

#141

I have DD app version 3.1.0 on my previous LG smartphone, and the Mavic Air could fly. With my Note 8 on DD app version 3.4.0, I get the controller error that many others are reporting. I hope that helps the team in fixing this issue. Thanks!

0 Likes

#142

Can anyone provide feedback on which app version of DD you are using and if your Mavic Air flys with it? Can anyone from DD provide feedback on this possible app version issue as well? Thanks.

0 Likes

#143

v3.5.0 on android, just recently released - works perfectly on my Mavic Air!
Had been trying with v3.4.0 , and was having issues getting through pre-flight checklist, something to do with the flight mode options in DJIGo

0 Likes

#144

Sean, thanks for the response. I’m on DD version 3.5 also, but still having issues. I’m on DJI Go 4 version 4.3.14. How about yourself?

0 Likes

#145

Same, DJI Go v4.3.14 - I have also recently updated the drone & controller firmware (but before the DD app update - so not sure what effect it might have).
Have you checked that DJI Go isn’t set as default app in android settings? I believe having it set as default messes with DD trying to take control.
Failing that, it may be time to pray to the drone-gods and call tech support?

1 Like