Mavic 3E RTK with Dronedeploy not connecting to RTK network

I am having trouble getting the RTK to connect in DD.

DroneDeploy released access to their own RTK network that is nationwide. I tried to use it and drone is stuck at “connecting to RTK network”. I tried leaving drone for 20 minutes several times. I also paid for the NC RTK network and this network has had luck at this location in Pilot 2 app. It also is very finicky and only connects when the stars align! I checked the MAP in the press release and I am in a bright green coverage sphere.

Anyone else try the DD RTK network yet?


1 Like

Ok, further testing revealed the following, at my location the RTK signal is weak on the ground. In the DJI Pilot 2 app it allows you to initialize RTK while hovering, if I put the drone 200ft up in the air, it is able to obtain an RTK lock almost instantly. On the ground it is very very finicky and a real headache. I tested disabling and reenabling on ground and does not lock, but in air it connects. Once RTK is connected the drone can land and does not lose RTK signal. I think dronedeploy needs to allow us to do a RTK hover lock or else what is the point. So many launch sites will have poor RTK at ground level!

Keep in mind that data connections and radio signal have a lot to do with RTK connections on drones as well. If you have a high latency or jitter you will likely experience problems above and beyond satellite health, multipath and ionospheric interference.

A few things to think about,

  1. What is my network speed?
  2. What is my latency (ping) and jitter? (You can obtain these at
  3. Did you have at least 5-7 satellites on all constellations?
  4. Were any of the constellations bouncing?
  5. What are my standard deviations?

Unfortunately Pilot 2 doesn’t supply SnR, HDOP or PDOP values which are actually the most useful when troubleshooting problems obtaining a fix so there’s only so much you can do. The other thing I have requested on the drone side is the ability to cut dirty constellations. Beidou and GLONASS are documented to have trouble in our area at times but unfortunately without those other statistics there is no way to tell if that is actually a problem on a drone.

I guess my issue is more about function. I know that I can get an RTK lock no issues and immediately 100-200ft up where the mapping occurs anyway. Getting an RTK lock on the ground next to metal or in a bowl is problematic. Never get RTK lock, or get immediate and perfect RTK lock instantly.

Now you can start to understand why GPS receivers are mounted on tripods and poles and why some of us have issues with aeropoints collecting data on the ground. Regardless, data is usually the main culprit. I flew of a job yesterday that would not allow me to get a fix from the network so I set up my local base and fixed within 30 seconds. There’s no way I can rely on the “DroneDeploy network” in my area.

The rtk is so sensitive, if i hover my hand over the tophat for a second it breaks the data link.

We’ve been having issues and testing this ourselves.

DroneDeploy uses a 3rd party RTK network with very limited base stations on a national level.
We were able to connect to this network using the DJI App but not the DroneDeploy app.
After running our results past their engineers, they seem to think its an issue with the DD algorithm.

As far as accuracy goes, we got the best results using the NC state network and the new PPK beta-testing which were near-GCP level of accuracy.

1 Like