Can't connect M3E to DD! Please help!

Hello,

First off, I am new to drone mapping, and currently taking a mapping & modeling class using DD. I have been through the initial setup guide and all the troubleshooting info I could find, and just can’t get DD to see or connect to my M3E. All firmware is up to date, DD flight app on RC Pro is the latest version, downloaded and installed from Amazon app store, and recommended permissions set on controller. Flight planning and execution works fine in Pilot 2 app.

The mission I planned on DD web app shows up on my controller, but I see no option to “fly” the mission. the “connect drone” box and circle with the check mark (pre-flight check?) on the bottom right of the DD fly screen do nothing when I tap on them. I have been through everything multiple times, uninstalled/reinstalled the DD app. Done a test flight in Pilot 2, force-quit that, started DD, and nothing. I can’t for the life of me figure out what iot could be, and figure it’s got to be something little that I’m missing, so I thought I’d try this forum.

Help me Obi-wan Kenobi, you’re my only hope…

2 Likes

Update: Solved, with the help of my instructor.
In case anyone runs into this problem, here is the solution:

  1. Power on the RC Pro controller, go to settings, apps, and then force quit everything including the settings app. Power off the controller.
  2. Then, in this exact order:
    a. Power on the RC Pro and wait for it to fully boot up.
    b. Power on the M3E and wait for it to initialize.
    c. Start the drone Deploy flight app.

Worked the very first time and the drone connected instantly. I cycled everything again, and it connected instantly again. I was told that it may take a couple tries, but I was happy it worked the first time. Good luck!

1 Like