First Flight - Checklist - Mission - unable to load?


Today was the first time I tried out the DroneDeploy!

I created a mission at home. I went out… should have played around at home first as I was struggling to find the Mission - Would be helpful in the main menu to have a load missions - organise by date created - search - etc. I think you get the idea.

I couldn’t find it at first so I went to create a new mission…

Everything loaded, checklist was being complete (eg. gps, remote, camera, etc.)
However - The Mission was just constantly loading. Am I being impatient or was there something wrong. I left it to load for 3mins or so. Still no change.

Tried various senorios, eg. Open DJI Go, Close All Apps, Reload Deploy, Open DJI first then Reload Deploy… Nothing worked.

Until I found the old flight mission and then clicked launch… worked straight away…

I just need to know about the creating mission when away from home. I was using a Nexus Tablet - not connected to wifi or any internet single.

Thanks in advance!

You can create a mission at home on your desktop. If for some reason it doesn’t show up on your phone you can click the ‘sync’ button in the sidebar. sometimes this helps.