Can't sync missions


I’m having problems with getting the app sync any missions.

I plan them on my desktop and click to sync. Then when i open the app on android it’s only “waiting for drone”

I have flown two successful missions a week ago but now i can’t get it to work.I removed the app and downloaded again from play store several times (1.4.5). It’s as if the app and desktop don’t communicate. Even creating a new account does not help.

If i click “new mission” in app i when connected to drone i only have white screen, no map.
“data explorer” shows no plans with data, not even the demo ones.
Simulator functions as expected.
Clicking “offline sync” does nothing.

Inspire 1, X3
LG G pad 8, android 5.0.2

Any ideas?


Could you send us a video of this at I haven’t seen this behavior before so I’d like to see if we can figure out how to reproduce it at our office.

I have that problem too. Version 1.4.5 does not synchronize.
Inspire 1 X3 1.05.11
Android 5.1.1 and Android 4.2

1 Like

I made this (shaky) video:
maby it’s of some use.

Today i tried to make a new mission on site, without desktop planning. All went well untill checklist, where all other but mission was green. Mission kept loading but got nowhere, and i got a message “something is wrong”

I have the same sync problem (iOS, Inspire, X3). I too did a ‘new mission’ onsite, and during the checklist countdown I got the same ‘something is wrong’ mission error message. I closed the DD app, and checked that DJI 'GO" app was fully closed, and then re-opened the DD app. I started a new mission and was able to successfully get through the checklist and fly the mission.

Thanks koavog, i’ll make sure go is turned off next time. I usually do a force shutdown on it but might have skipped that today.

More problems again.

After a manual flight i uploaded the pictures for processing and all went well. But when i wanted to make new map with same photos after some lightroom editing, i only get a partial map. It did upload all 110 photos both times and still shows it has them all, but the lightroom edited map is about 5% coverage.

Retrying gives “failed to upload, retrying” message on both IE and chrome and on two accounts.

Looks like it might be an issue with the files after they were processed in light room. Could you send us a link to the photos in Dropbox or something at so we can try them to see what the issue is.

Yeah i guess i messed up some details when exporting from lightroom, it somehow shrunk the map. It looks like all the pictures are there but the map is squueezed together.

I’ll send you a google drive link to the photos if you can help to find out what’s wrong.

I ordered an ipad today to test out mission syncing with that at some point.

I am also unable to sync the desktop mission I plan with the app, whether I am onsite or offsite. When I run the app, it says Syncing, but nothing gets ever synced. I do not mind redoing the missions - which is a drag anyway you look at it - but the DD app on Android does not give you the Precision option the desktop app does… Why is that? I get to control only the height, the front and side lap. The height is also misleading in the DD Android app, sometimes it shows when you press the circle button on bottomleft, sometimes it does not. After you input the height, there is no Enter button, you have to press Back and it stays like you have input it, again misleading. Please consider the above two as improvement requests.
What I consider a bug is the fact that when the drone loses contact with the DD app, the drone still flies on the preprogrammed mission path, but it does not take any pictures…If it can be programmed to fly, why can’t it be programmed to take stills? I can do that in lesser apps, like Litchi. Another improvement request would be to increase the speed at which the drone ascends/descends at the mission starting point. It takes so long to do that that attracts the attention of bystanders. At least above 10 meters above ground level.

I’ve added some of these to our current bug list.

We aren’t able to ascend or descend any faster using the DJI sdk.

It should continue to take images when you lose connection, if it doesn’t please let us know a flight of where it stopped so we can check the logs.


It was this mission
It does not replay it for some reason on the DD desktop, maybe you need to look into that as well.

I have both of these problems as well, It will not sync with my android tablet, same symptoms, and when in the Desktop dashboard it will allow me to change the altitude/front lap/side lap as well as the size of the mission polygon, and it appears as changed, but upon returning to the main page and re opening the mission it returns to the initial mission polygon size and the default altitude and default lap settings.

1 Like

DD v1.4.4, Inspire 1, X3 camera, iPad Air v9.2:
Still not able to sync missions. It shows synced on the on the desk top, but it doesn’t show up in the field.

I tried that. Still does not sync… Why would be syncing in DD related to DJI Go?

Ronald, I tried your suggestion, but it still didn’t work. It shows synced on the desktop but will not appear in the field within the pre-planned coordinates.

Hi @koavog,

We have resolved most of the syncing issues we knew about on iOS in the release last week. If you are still having problems I’d be interested in setting up a skype or google hangouts call to see if we can figure out what is happening on your ipad. You can PM me any details if you’re able to chat.



Hi Chase, Thanks for responding. I’ve resolved the issue. I was stuck at finding the new (synched) mission. When I open the app and the generic grid appears, all I need to do is click on the “older” right arrow on the right side of the page and it takes me to the synched mission. If that “older” arrow doesn’t appear. Clicking on “Offline Sync” will cause the “older” arrow to appear

In Documentation under “Desktop Planning” it seems to be specific to the android. Is it possible to include iOS specific documentation?

Also, as many time as I’ve read line ‘6’, I can’t make sense of it. Do you mean; “Press the Offline Sync button in the panel at the left, wait for the “Older” right arrow to appear on the right side of the page”?

You guys are doing a great job. I’m very excited to purchase DD and start using when the Beta is complete.

Cheers! Peter

I flew a successful mission today by planning the flight on site with my tablet.

Syncing with desktop was partially successful, it shows the flight lines but no satellite map so i didn’t dare to fly with that.

I deleted all apps that control the I1( DD, Go, litchi, dronepan) and redownloaded DD, then synced maps and redownloaded DJI Go. Then with Go test taking a picture, forced it to stop, then started DD and it worked.

Got a few “photo failed” message before takeoff but it did take all photos needed.

I probably want to start using the precision version for work, depending on what my client chooses for accuracy, so hopefully we have a stable app soon!

1 Like