Error message trying to use Drone Deploy with Mavic 3E

We recently purchased a Mavic 3E for mapping purposes. One of the selling points was that it is compatibly with DroneDeploy, which I used extensively with our Phantom 4 Pro.

Today, I installed Drone Deploy on the RC Pro. However, since it doesn’t have Google Play, I had to use a work around and copy the APK file to the device and then install. That worked marvelously. However, when I try to use DroneDeploy, I get a message that the app requires Google Play Services, which isn’t supported on the device.

DroneDeploy has hyped the Mavic 3E, so I am wondering what I am doing wrong. Any advice out there?

1 Like

How do I install the DroneDeploy app on the DJI RC Pro Enterprise smart controller?

You will need to install the DroneDeploy app via the Amazon Appstore.

  1. On your DJI RC Pro Enterprise smart controller, open this webpage ( and tap here to install the Amazon Appstore.
  2. Log in to your Amazon account.
  3. Tap here to download the DroneDeploy Flight app (or simply search for ‘DroneDeploy’).

You’re now ready to fly with DroneDeploy on your RC Pro Enterprise smart controller! For the best experience, it is recommended to force stop the DJI Pilot 2 app before starting DroneDeploy. To force stop DJI Pilot 2, go to the device Settings > Apps & notifications > DJI Pilot 2 > Force Stop.


Great balls of fire, that appears to have done the trick. Interesting that the apps vary depending on whether you grab it from Google Play or Amazon Appstore. I guess I shouldn’t be surprised.

Many thanks,


1 Like

Glad to see that it worked out!

Good Stuff, I had to delete all the other stuff I had tried.
But then I found your quick & Simple guide. All working now.
Thanks MichaelL