Dronedeploy not launching after Android 7 Security Patch Update


#1

Summary of Issue:

I had no problem last year operating our DJI Mavic Pro, switching between DJI Go 4 and Dronedeploy to focus the camera. This year on my first mission Dronedeploy did not launch if switching between apps. It is as if the Samsung Galaxy S7’s usb is now dedicated to DJI Go 4 app as this is the only app launching. DD launches fine when not connected to the RC via usb. I have uninstalled both apps and reinstalled, cleared app defaults and still the problem persists. I suspect it having something to do with the Android 7 security patch which installed December 2017. I tested this on my partner’s phone (Not Samsung but also Android 7) which also worked last year and the same problem occurs. Anyone having the same issues? Any assistance will be appreciated!

Date Issue Began: Jan 2018

Drone Model: Mavic Pro

Mobile Device Model and OS version: Samsung Galaxy S7 - Android Version: 7.0


#2

I am not sure if this applies to your case but for my DJI Phantom 4 Pro here is what I need to do in order to switch from DJI Go 4 to DroneDeploy:

  1. Bring up DJI Go 4 and check that all items for your drone are ok. Make sure Return-to-Home location has been set.
  2. Quit DJI Go 4 and make sure it is not in the list of active Apps.
  3. Go to settings > Apps > App manager > DJI Go 4 > scroll down to Set as default and then if this is active (not dimmed) click on it and then click on Clear defaults.
  4. Get out of settings
  5. Unplug USB. Re-plug USB. A window should pop up asking what App should get the USB > select DroneDeploy
  6. Start DroneDeploy App
  7. Does it come up?

You said you were clearing app defaults so you may already be doing all these steps in which case I have no more suggestions.

Regards,
Terry.


#3

Hello @Braam_G,

Thanks for reaching out. We are currently experiencing issues with Mavic Pro users who have updated their DJI firmware. The firmware is preventing our application from working properly when it comes to camera settings. If you are having difficulty in having your Drone take off for flight, then the issue might be attributed to this known issue. We do have a workaround for this if this is the case.

I would update your app to our latest version. Are you able to connect your drone to the DroneDeploy app?

Thank you and we hope to solve your issue as soon as possible.


#4

Hi Terry,

All of that has been tried. The problem is that DD does not even launch when the RC usb is plugged into the Galaxy S7.

Regards,
Braam


#5

Hi Yusuf,

I do not think it has anything to do with the Mavic. As mentioned to Terry. DD does not even launch when the RC is plugged into the Android phone usb. Both our phones were able to work correctly last year, but not after the Android updates.

Regards,

Braam


#6

Android used to work great with Marshmallow (OS5) on Samsung devices. When they went to OS 6, the way Samsung did Android made it rather difficult to connect. Apparently they did something in this patch to hinder that even more.


#7

Hi Gary,

Thanks for the feedback. Is there a work around or is that it.


#8

Hi @Braam_G,

Just a suggestion here, but have you tried a different cable for your Android? Sometimes switching out the cables does the trick, though not always. Do you have another device you can test as well?

Cheers,
Christina