Unable to Start Mission

I have been unable to find the button that allows me run my mission on drone deploy. I have gone through the required process to plan the mission, however when I am set to begin after saving the mission plan, I am unable to locate the button to allow me start the mission

I have been having this challenge since i first tried using drone deploy on June 18, 2018 with my DJI Mavic Pro Platinum.

I use a Samsung J7 Prime running on Android 7.0

and I am using the drone deploy version 2.75.0

You’re not seeing the checklist icon at the bottom right side of the screen? Hmm…

Yea…No checklist when I’m done setting up the mission. The only icon on the bottom right shows me option to; upload images, create folder, etc but nothing about starting the mission.

Can you logout, go into the Android app settings and clear the cache/memory then log back in? You may need to get DroneDeploy to get you an older version of the app if it turns out to be a bug with it and your device.

I’ll give that a try and share the outcome. All I see at the bottom of the screen below the previous Icon I mentioned are the “test simulation and don’t have a drone?” Buttons. When I hit the test button it shows me the simulation as planned but also notifies me that it’s not a real drone flight and when I stop simulation it shows a prompt saying drone disconnected.

Yeah, it doesn’t sound like you’re connected to the drone. When you open the app you should see ‘Drone Connected’ flash up at the bottom of the screen in white and once you’ve entered a mission from the dashboard you’ll see an arrow and blue fly button in the bottom right corner. Click that, it uploads all the necessary data to the drone and carries out half a dozen checks and once ready it will invite you to press the blue button again to actually start the mission.

I note that your device is not one officially supported by DD so these procedures might not work, but they’re worth a go.

Without the RC controller connected to the phone and both the DJI Go 4 and Drone Deploy apps closed down:-

  • Go to Settings, Applications, select DJI Go 4, scroll down to Defaults and click clear.

  • Do the same for Drone Deploy.

  • Switch the RC on and plug the USB cable into the phone. You’ll see a prompt come up asking which app to select as a default. Select Drone Deploy. It may open up on its own but if not manually start the app. If you see that the drone is connected by the prompt at the bottom of the screen you’ll know it’s worked and the ‘fly’ button I mentioned before will appear once inside a mission. If not then I think it is likely to be a compatibility issue between your phone and Drone Deploy.

You’ll need to remember that if it works, you will have to do the default clearing procedure of the apps (without the cable connected) every time you switch between the Go 4 app and Drone Deploy. A bit of a pain but that’s an Android thing and why I bought an iOS device - just to operate Drone Deploy. You would still need to close one app before opening the other but there’s no pulling cables and clearing defaults etc.

Good luck. J.

Hi @Emeka_Azuh,

I just wanted to hop in and share a couple of our Support pages with you:

  1. Supported Drones
  2. Supported Devices (Mobile and Tablet)

Please note that if your devices are not listed on these pages, we cannot guarantee that DroneDeploy will or should work without issue with your setup. Can you let me know if you have the same issues when using officially supported hardware and mobile devices?