DJI Air 2S iOS Beta

I had to upgrade my plan to use my DJI Mavic Air 2 S, fine. But when I try to use the pre-flight checklist it says there is minimum support for my drone. SOOOO how do I take off without going through the pre-flight checklist?

Support isn’t official or even beta at this point but it is coming. Hopefully before the end of the year.

I have the same problem. I had the Beta activated. The air 2s connects just fine but when I do the preflight checks I get the same message you did. There is no way to move past and take off. So how is this supposed to work?

1 Like

More than likely it’s a bug that needs to be reported directly to support. I renamed this thread to reflect the beta status. Looks like I missed the release of the beta while I was on vacation. Signing up now!

Actually I just found out that the support doc hit before the actual release of the open beta which is next Monday the 18th. Contact support to make sure you get included.

Ran the Air 2S beta today on an iPad Mini 5 and received a notification stating, “the camera is unable to focus”. I was running manual and haven’t tried mapping yet but will this weekend or early next week. @AlexHennessey

I tried to use my drone yesterday, I paid the service in order to fly the Air2S and is not letting me pass the checklist, I tried with different mission types and it connects but is not going though the checklist.

1 Like

What step is it failing on?

Not trying to pile on here, but I have the same problem.
Waiting for a reply from support.


Hi team -

The DJI Air 2S has a few requirements I want to ensure are being met:

  • you have a paid subscription or active trial
  • you’re connecting on an Apple iOS device
  • you’re operating app version 4.97 or later

This should allow flight. Please let me know if otherwise!

1 Like

Hello All,

I received an email back from Drone Deploy. The problem has been fixed :grinning:

Please update the app to version 4.97 - it looks like you’re on 4.95 which will prevent flight.

1 Like

Thanks for sharing pga!

What about the RC pro Controller?

1 Like

Test flight yesterday with map and pano except pano does not appear to be available?

-Test image failed
-Controller in wrong mode


Hi All, I am flying an Air2s on IOS iPhone XR or iPad Pro 2020, DD version 4.98 and I continue to have camera calibration issues that interrupt my flight. Initially I can get through about half a mission no issues at all, then suddenly there are either camera calibration or RC connection errors.

Signal strength for RC on the app is always strong. The latest update for DD states air2s camera calibration now supported but not sure something is still wrong. I have only been able to complete one small ~6 acre mission.

1 Like

Just got a DJI Mavic Air 2s. Several issues whilst using Drone Deploy. Connection issue first with controller during a mission. Missed photos on a flight plan. App freezing. And lastly an error in the camera preflight check and focusing the camera on the air while flying. This made me to land and complete the mission with a Mavic 2 Pro Hasselblad. Could it be that the drone is new on the software is new on the app?

Have a search through the forum, there is a fair bit of info regarding the Mavic Air 2. Have you tried deleting the app and re-downloading it?

You are correct. This is a public beta but still a beta nonetheless. We haven’t even been able to start a mission with ours and I don’t have time to tinker right now. @Farai_Masheke @AlexHennessey

It’s the DJI Air 2S, not the Mavic Air 2. Although it brings up a good point of how people are doing with the MA2. It seems like after all the activity that after the Air 2S came out the Air 2 just went away.

Attempted a simple 2d mapping mission with the Air2s. DD goes through the pre-flight o.k. Then it takes off for several feet and hovers, does a camera calibration and at the same time gives an error message and says to push the “play” button to continue the flight. When it goes into this error mode it switches from autonomous to manual. After pushing the play button it goes back into autonomous, then immediately displays the error again. Restarting, rebooting, etc. has had not effect. I have done several mapping missions with a P4pv2 at this same location without a problem. Any help regarding the Air2s will be appreciated. (I have done all of the standard troubleshooting. Firmware, programs are all up to date.)

1 Like