Air2s with RC controller

I have a Air2s and trying to get started with Dronedeploy. I have the upgraded RC controller and I get the feeling I need either the basic or RC Pro for this to work. Can anyone confirm? I still have the basic controller, but would like to use the RC if possible.

Thank you in advance for any advice.


1 Like

Hey @Rocky_B, the Air 2S currently only works when paired to an iOS device (iPhone, iPad) and not the RC Controllers.


What do you mean by paired? Like with the old controller connected to the ipad? I was just trying to use my air 2s and it didnt work at all with my android, i connected it to the ipad everything’s seems fine, but when i click “start” it doesn’t take off, it says initializing, then it doesn’t do anything.
Any idea on how to get past this issue?

1 Like

Hi @Liebherr_cat. To fly the DJI Air 2S you need to use the DJI RC-N1 Remote Controller (the Air 2S controller without a built-in screen). You also need to use an iOS device as it is not supported for Android currently. Additionally you need to either have a subscription to DroneDeploy or be on a trial for flight.

You can find more information on supported drones here.

Hope this helps!

I did use an iPad (ios), and I used the RCn1 controller, everything seems fine, the checklist is all green and it says to click start or fly I think, I forget what the button says, thing is that when I do it doesn’t take off it just doesn’t do anything, I restarted the drone, the app and controller and still nothing.
And I’m using the Air 2s and the controller you said.

I have found that I need to start the drone and fly up a bit before starting. YMMV.

I’ve never seen this personally. It is very strange how we can experience so many different behaviors. @Ian-Sullivan @Liebherr_cat What iPads are you using? I’m on a 2021 11" iPad Pro.

I’m thinking it’s because the DJI SDK’s are very inconsistent and quirky (and buggy).
I still get that “Invalid Flight” thing from time to time.
Also it seems like for the MP2 if you don’t have DJIGO running, it can’t connect to the camera.

I’m having the same problem. Trial Version (got it specifically because DroneDeploy advertises the Air 2S). Air 2S with most recent firmware. RC-N1 controller. Multiple iOS devices attempted. Will start mission, take off, fly to start point. Then it errors about camera focus, then a general error message prompting my to hit play to resume. Hitting play loops the same errors. I tried changing the mission to manual focus in FJI Fly and the camera focus error went away, but the other error remains unchanged.

I hope this can be resolved. If I still have to break out the Phantom 4 for even small mapping missions I think I’ll stick with other services. The ability to use the Air 2S is what brought me here.

1 Like