DD changing camera to auto from manual


#1

Just started using DD a few days ago with my P4P on android. Made two maps with DD in auto mode for Camera settings, but noticed the exposure was a little too high and possibly a little blurry from the shutter being too slow maybe. So the next maps I set the camera to manual on DD and set the camera on the P4P using the DJI app.

At first I used shutter priority mode on the DJI app with a shutter speed of 500 I believe. Set white balance to Sunny and ISO to 100. I did all of this while at my mapping altitude. So I exited the DJI app, closed it, and started the DD where I proceeded to map my area. Everything looked fine on the picture window in the corner of the screen, but when I got home with the pictures and looked at them before uploading them I see they were all underexposed. After looking at the metadata for the pics I see the shutter had increased to 800, from 500 where I set it.

So I started up the DJI app again to see what the camera settings were and everything was on auto, even White balance. The ISO was still 100.

So i then set the camera to manual mode and sunny white balance. Set all the settings where I wanted them and tried again. It once again changed shutter speed, but everything else was still where I set it I think.

I tried mapping a test area multiple times. At first the camera view in the corner always showed a bright image. But in some of the later flights it would start bright then go dark. At first the live view would be bright but the images it was capturing were dark. I had one pass where it made it about halfway through a pass using the manual settings, but then it increased shutter speed and I once again got dark images. Most of the time I get all underexposed images, except for the test shot DD does right at the beggining.

So long story short, it appears something is changing my Manual camera mode to Auto at some point. As well as my white balance from Sunny to Auto. And somtetimes it will still be in manual mode, but change shutter speed at some point.

Any Ideas or people seeing this as well.

thanks,


Mavic Pro Can't focus
Custom Camera Settings Not Working - Inspire 2
DJI GO manual settings change when Dronedeploy app starts mission
#2

Just went out again.

DD in manual camera mode. Made camera adjustments in DJI app.

Auto Camera
Manual ISO 100
Sunny White Balance
Auto Focus

When I got back from making a pass, settings had changed too:

Auto White Balance
Manual Focus

Images are usable, but seem a little overexposed. Shutter and Aperture were changing as you would expect since it is on Auto Camera.

Will try some more combinations and see what it does.


#3

UPDATE

Spent a day troubleshooting. It appears when you press the RTH button on the remote or possibly on the DD app, the camera settings in the DJI app go back to Auto along with the White Balance.

So that explains that, but I am still getting changes to shutter speed even before it returns home. It usually changes right after the first couple pictures taken.

I tried an iPad and it appears to keep the camera in manual mode while taking pictures. All the pictures appeared to have the correct exposure and the Metadata showed that all the pictures kept the manual settings I set in the DJI app before using DD.

The only thing that appeared to change while using the iPad was the Focus went from Auto to Manual. This happens with Android as well.

The majority of the problem appears to be related to the Android App


#4

I’m having the same issue. I don’t have an ipad however. Everything I do is Android based. I really don’t want to purchase one just to avoid the problem. I’m considering pix4d for my planning software though.


#5

Well pix4dcapture and Ctrl+DJI aren’t working…
Still haven’t found a way to resolve the focus issues by tweaking my current setup. Really don’t want to have to buy an ipad to try that route.


#6

I was going to try Pix4d today.

I’d rather use Android myself. Hopefully this can be fixed sometime soon, because other than these issues DD appears to be a good program that is easy to use.


#7

I should clarify. The app simply won’t connect with my drone. I didn’'t find a simple fix or procedure for this. I have to dedicate some time to other job tasks.


#8

Im using a Nexus 7 tablet and just got back from doing a test run.

It appears to have held the camera settings I set with the DJI app. I first started the DJI app launched the P4P and set my camera settings while in the air. I then closed the DJI app and pulled the USB cable. Then started the Pix4d app and ran my mission. Completed the mission, pulled the SD card and inspected the Metadata on the pictures and they all had the settings I set in the DJI app.

Will do some more tests but appears to be working


#9

I tried my K1 Tablet and S8+ phone. Didn’t make a difference.


#10

After the Pix4d app starts the CTRL+DJI app pops up on the screen asking to use the USB connection or whatever it says. I say ok, but thats about the only thing I do


#11

Thanks for these detailed reports. We are looking into a fix for this.


#13

I set the mapping area up and turn off automatic camera settings.
I launch the inspire 2 and ensure the exposure is ok in manual mode.
Land
Shut down DJI Go 4
Launch DD
DD then proceeds to take photos at different camera settings?
Why would it change settings to ISO100 - 1/120 - / F3.2
My camera settings were ISO 500 1/200 - F8

Im not seriously considering using another application for mapping as i have wasted 3 days trying to map the same bit of moorland, i would appreciate some feedback.


#14

Hi @StevenGourlay,

This is an issue we’re currently investigating and we hope to have an update to share soon.

Cheers,
Christina


#15

Im having this problem as well with Inspire 1 Pro/X5. Looking forward to the update.

It seems like the last few app updates have caused problems that shouldn’t be too hard to spot. How much testing is DD doing befor releasing updates?


#16

Hi @brianpgreen,

We’re working diligently on our end to provide a solution to this issue as soon as we can. I understand that it’s frustrating running into issues or bugs, but we do value and appreciate feedback that you’ve shared with us so far. We’re continually working on making improvements and changes so users like you can have a better experience. It may take more time than either of us would like, but we are trying to get there.

Cheers,
Christina


#17

Thanks Christina. Would it be possible to set a floor on the exposure time even in auto mode? I always prefer to use manual and set my own parameters so that the exposure is fast enough. If I have to up the ISO I do so. I can’t come up with a situation in Drone Deploy where I’d want an exposure slower than somewhere around 1/400th of a second. (Maybe that’s not the right number but you get the idea. We don’t want long exposures when the drone is moving)

I might use auto mode if I could be confident that Drone Deploy wouldn’t select exposure times that are inappropriate for the speed the drone is traveling.


#18

Hi @brianpgreen,

Unfortunately you won’t be able to set your own exposure in DroneDeploy.

Cheers,
Christina


#19

Hi @brianpgreen on iOS I can enable a new mode which will automatically set exposure and it will have a floor for the shutter speed and try to keep a low ISO.
It’s not enabled for everyone yet because we are still collecting data to make sure it works consistently.


#20

I also faced the same problem, How to solve this ?


#21

Thanks,
It is weird. while I took of the automatic camera settings in DD, set the right camera parameters in DJI APP, Normally, I used shutter priority, like 1/600 or faster to avoiding blurry photos.
Then, closed the DJI app,
In DD, PLAN the flight and take off, at the beginning the first taken photo was under the shutter priority mode. while the drone arrived at the first shooting point. The mode switched to auto mode.
I tested in Phantom 4 and 4 Advanced.
Changing is still there.
Sometimes, you do not know which mode the drone will take during the flights. Likely, out of control in shooting.