DD and Healthy Drones Flight Logs

The HD and DD Flight Logs seem to work sometims but not often. Ive found I have luck more with my P3P than Inspire 1. But an issue ive found now is the flight logs are only capturing small parts of there mission and not the whole. The missions I few recently had the batterie on 20% on landing but in HD the fliles only give a portion of that. Thought you may want to know, and would like to hear from other users with the HD and DD flight logs.

Thanks, we’re investigating this.

I’m having the same problem with the Mavic Pro

I just uploaded one of my DD logs to Healthy Drones. This was the first log I have uploaded. It only showed about 1/3 of the mission.

Not information on my log. The drone flow a few minutes but not information on the log . I have mention on other posts there was not white line showing the flight of the Drone during the mission. Also not window showing camera view. See image.

Where are you getting the DD flight logs? Are they stored on your mobile device?

Ok, so not on my device but stored online I see. However, none of my missions seem to have any logs, “No Flight Logs Available”

I think they made something wrong with the last update of the app DD used to work excelent but not any more. Now many users having the same problem, the Drone fly but not pictures taken. Hopefuly they will solve the problem in the near future @chasemgray

Hey, @cidcarlos can you let me know if you see the camera check when you’re on the checklist before a fight? There should be 5 checks in that list. I have an idea of what is happening for some of you and that would help me figure it out.

Hello. Yes it chek the camera memory and marked it green. It passed all the list to green. Then take off but never show the camera window. Just other thing I can remember is that in some ocasion even the RC was not in F mode the check said it was Ok, but it did not send the waypoints to the Drone and the app then stop responding.

You originally said you were flying. How were you flying without sending waypoints?

P4 with Nvidia Shield K1 tablet, Nougat 7.0, and my logs that I updated HD with are reporting what I think are really metric heights but as imperial. I fly in imperial and my missions are typically at 155 ft, and the uploaded logs appear in HD as 45-48’. I am grateful to still be using 2.0.18, and not updated the new dreaded release.

Did someone ever answer OP how to roll back the previous version in case I accidentally update. My phone has the dreaded latest version.

Is anyone here available to maybe do a video chat while going through a flight on a drone so we can see the issues you’re facing with the latest version?

Hello @chasemgray, sorry, my English is not my native language. Yes I was flying when there were not pictures taken. I mentioned other issue that the new version of DD is doing, when I tried to connect the drone with the J7 Sansumg cel. It connects, start to check the check list but being the fligth mode in P the check list marked this as done (as if it were on F mode) which is an error, then when the app was trying to send the waypoints to the drone, that check is never ending, so I have to close the app and restart. Then the check list recognizes that the RC is on P mode and ask for F mode, you do that and waypoints are sent to the drone and the mission started. It fly but not a single picture is taken, and on the cell screen there is no window for pictures, and the fligth route is followed but not recorded with the white line as used to be. I will try to make a video for you tomorrow. Thanks for your concerm.

Puedo hablar espanol si quieres.

Ok great, do you SKYPE? my user name is cidcarlos on SKYPE, if you want we talk.


Sure, I’ll message you in just a bit.

I’ve had similar issues with the flight logs. Sometimes the Download flight logs link is enabled and sometime it isn’t. I’ve tried leaving the drone, controller and app powered up for up to 10 minutes after the flight in case it was simply a slow download of data if the log file is large. Again, after numerous tests, it works intermittently.

When the download flight logs link is enabled after a flight, the logs are partially complete and only part of the flight appears in HealthyDrones (AirData).

I haven’t seen any pattern to this behaviour.

As a software developer myself I know how hard it can be to track down bugs that aren’t 100% repeatable. If you need my data or would like me to run any tests, let me know.

The upcoming release should improve the flight log uploads and also allow you to access them off of the phone manually if sometihng goes wrong with the upload.