Connecting with Mavic Air


#1

I flew my first successful mission with Drone Deploy a week ago using my Mavic Air and it was real cool. Today I tried to fly another mission and could not get the remote to connect to Drone Deploy no matter what I tried. I eventually gave up(frustrated) and now I’m hoping someone can help me get back out doing missions. After my first un-successful attempt I did try connecting with DJI Go 4 and it worked just fine.

Things I tried:

  • Power cycled everything including the phone.
  • Re-installed Drone Deploy
  • Un-installed DJI Go 4
  • Cleared all defaults and made sure all app closed
  • Un-plugged and re-plugged the remote from the phone while the remote was on
  • Re-started phone with Drone Deploy set as default

The Drone Deploy app simply will not connect to the remote, I’m totally stumped and now I’m hoping someone can help me.

Cheers!


#2

Hi @btc1020

I ran into this same issue with the Mavic Air a few months ago… it wouldn’t connect in DJI Go, either, which is what you’ll want to check if you’re not sure why it’s not working in DroneDeploy. It turned out that the remote needed to be re-linked to the drone.


#3

Make sure you are clearing the defaults in other apps like aeroranger, go 4 etc. If they get default, you’ll never get DD to work