Map mission won't start, Mavic Pro, Samsung Note 5, Android 7.0

So, I’ve got a mapping mission planned at 400ft (via the web). I go to the site today, start the controller and the mavic pro, open DD, load the mission. It says “drone connected”, then says “You can increase max altitude in your account settings.” (I just checked, and my max altitude in my account settings is 400’.) So, for grins, I set the flight altitude to 390ft. (Could it be I’m using terrain following, and it thinks part of the flight will be over 390’??)

I “Start preflight checklist”, it says “Checklist complete! Tap the takeoff button to begin.”

I tap the “start flight” button. I see “Drone is initializing…”, then the motors start, the drone takes off, the camera points straight down, it gets to 7’, and then…does nothing else.

I manually flew it up to 30’; no change. I manually flew it to a different spot. Missions still doesn’t start. I hit the “home” button, the drone happily comes home and lands, with a screen that says

I tapped “Reset Flight”, and went thru the whole process again, and got the exact same results.

Thoughts on how to fix this? Thanks!

1 Like

Well, I got no replies yesterday, so I did some experimenting. Drone Deploy, are you reading this?? I’m going to relay the entire, agonizing process so you can hopefully understand the issue and get it fixed. (I’m sure there are a lot of people that have no issues; but my experience does NOT make me want to spend $300/mo on your software.)

Here’s my story.

I came home from the field, defeated (see above), I charged up batteries and created a test map above my house, then went out to try and fly it.

Drone and RC on and connected. Manually fly to 7’ in the middle of the backyard, no usb cable plugged into my phone yet. Start DD app. Plug in USB. DJI Go 4 app pops up, connected to drone. Kill that app. Back in DD app, I pull up the test map and get the “Drone connected” and “pre-flight checklist” button. Pre-flight successful. Click Start Flight. Away we go! It flew the mission and landed.

Cool, now to go back to the field to try re-creating that success.

Drone and RC on and connected. Manually fly to 7’ in the middle of the backyard, no usb cable plugged into my phone yet. Start DD app. Plug in USB. DJI Go 4 app pops up, connected to drone. Kill that app. DD won’t connect to drone. Force stop both apps. Start DD. Ok to “let DD see USB accessory.” DD doesn’t connect to the drone. Unplug / plug in usb. DD doesn’t connect to drone. Reboot drone, controller, phone. Do the above. DD still doesn’t connect. Messed around for 7 minutes with no joy.

Screw this, I’m burning battery. Start Litchi. Flawlessly run 4 missions over the next 22 minutes. As the drone is autolanding after the last waypoint, I canceled the landing at 150’, “exited” Litchi (using backarrow several times, so it’s still actually running in the background), and started DD. It connected right away to the drone. ??? Preflight checklist complete, the “start flight” button lights up. Tap it, but the drone starts landing because the battery is at 50%. I let it land, replaced the battery, and DD immediately connected. Checklist complete, start flight, and away it went, happy as a clam to thart the motors, take off, and then NOT run the mission…because suddenly there isn’t a mission loaded.


So I RTH, landed, got the “Mission incomplete; continue / reset”. I chose “reset”. Checklist complete. Start flight. Drone initializing. Flys to 7’ and hovers there…nothing else.

I manually land it, reset the mission, manually fly it up to 130’, and click preflight. The checks complete. Tap “start flight”. WHAT?? It now flies to 390’ (the plan altitude), and merrily flies the entire mapping plan.

This is not doable in a real-world, for pay situation. I am SO thankful that the company asking me to do a demo flight for them wasn’t there either of these times, and let me have free reign to experiment first before showing them this amazing technology. :frowning: As it is, at this point, I’m not ready to tell them that we’re good to go.

Any response from a DD employee would REALLY be welcome here. I have a screen recorder video of these flights, and any logs you want, if that’ll help.

@Anjanette_Hill @Andrew_Fraser @Jamespipe

@Anjanette_Hill @Andrew_Fraser @Jamespipe


@WildDoktor Very sorry to hear about this experience. Could you kindly send a note to so we can better explore what may have happened here?

There are quite a few improvements we’ve made to iOS that will be released in the next Android release before year’s end. Next year we expect to make Android a priority.


Bom dia colega de voo! Eu também já tive problema semelhante durante meus voos. Eu utilizava um Mavic Pro 1. Aqui no Brasil ele tem limite de voo definido pelo fabricante de 120 metros acima do solo. Nesta ocasião o voo seria para fazer um orthomosaico em 1.000.000 m² de área urbana com mais de 60 metros de declividade entre a parte alta do terreno e a parte mais baixa. No primeiro planejamento de voo eu não sabia disto e portanto me posicionei na parte alta do terreno e iniciei a decolagem. O drone e o dronedeploy voaram e formaram a orthofoto até a metade do terreno, pois o declive em relação ao solo ficou grande de mais. Então retornei para o escritório, descobri a altitude de 120 metros, pesquisei no “Google Earth” e planejei o voo no dronedeploy com a decolagem iniciando no meio do terreno. Assim correu tudo bem, porque ele sobrevoou a parte baixa, em seguida o meio e a parte alta foi a última. 1500 fotos para formar o orthomosaico. Coisa linda de se ver! Confesso que meu coração bateu mais forte ao ver ele sobrevoando edifícios de 15 andares. Foi aí que meu coração parou de bater, pois perdi o sinal do drone por várias vezes kkkkkkk mas ele continuou fiel à missão e deu tudo certo. kkkkkk

I just sent an email; thanks for the reply!