Large area issues

Hi guys,

We mostly use fixed-wings, but keep trying with DD and an Inspure from time to time.

With the latest release it looks like it is almost there, but I hit a few critical issues:

  1. multi-flight fails to recommence where it left off. It looked like it would work, as the start waypoint was automatically updated to 17, and I could see that on the map before the second flight, but after the pre-flight checks it resets the start waypoint to 1 and headed off to it exactly the same as the first flight

  2. KML input, can’t believe this is still missing! 99% of mapping jobs start with a KML from the client, so you need to be able to read these in for flight planning.

This is also needed for very large areas where you need to break it up into small flight areas to keep it in line of sight. The best way to do this is make multiple small KMLs from your big one, and flight plan to each.

There’s no way you’ll reliably get it right dragging points around and hoping the edges of the first flight area line up with the edges of subsequent ones

  1. transition flight speed: it is of course understandable that it needs to fly slow if there’s high forward overlap, but it seems to fly to the start waypoint at this slow speed. Better if it flew there fast, otherwise you can burn 10% of a battery before taking any photos

And some minor stuff:

  • should show the waypoint number it is heading to, so you know if you need to manually pick up from there next flight. This could be with the other info on the left, or drawn over the target waypoint where the target altitude is currently shown

  • flight speed was different in real flight to the simulator. Sim was 10 or 12 m/s, but it flew at just 4 in my test

  • I got the “waypoints more than 2km away” error each time I tried loading a flight plan I had pre-planned from the office. Restarting the app got past it, but seems to be a bug related to planning from one location and flying in another

  • if you turn on the second controller and run the DJI GO app it upsets DD (no photos taken, telemetry data stops updating). Understandable and probably documented somewhere, but DD didn’t throw up an error when this happened, silent fail.

  • sliders need numeric input, and decimals for angle of flight lines. This is really hard to get right in the current app if your site is on an angle

Heading the right way though, keep it up!

1 Like

We’ll take a look at the continue mission again to see if something is wrong.

We do allow shapefile planning. It has been in testing for a while. We can enable that for you. You would have to plan on the desktop though. We don’t yet know how to make this easy while planning on the tablet/phone

We are updating the flight speed when going to the first waypoint.

We are chatting with DJI to see if something has changed recently with the home location and those waypoint errors. People are seeing them more often now.

I’ll see if there is a way we can warn about DJI Go taking over the telemetry.

Sliders will soon have manual input.

Thanks for the feedback!

Excellent, thanks.

No worries on desktop-only planning for now, that’s the usual case. But at least displaying a KML/shapefile poly on the app version would help a lot in the field. It would be great if that was a layer you could turn on/off.

If there’s a different build I could get access to to try the shapefile planning that would be great.


I had some challenges with the return flight after swapping batteries on my first mapping flight. It returned to the same “waypoint run” except instead of flying to where it left off it flew to the start of that run and took duplicate pictures of what it had already photographed until it got to where it had left off and resumed. Just thought Id let you know Chase. On the next field it did what it should and all worked fine.


Flew another field today and this time it flew back to the last pass and started it completely again. More duplicate photos. Waypoint timed out again. This was after i downloaded the most recent DJI upgrade which came out today so that one hasnt contained the fix. I know it seems like we often complaining about what isnt working but I want to also say how great the app is when it is working. Keep up the good work.

I might have missed it somewhere but can you pick where the starting point is on a mission? Today I did a one mile long field and there was no way I could even adjust the size to get the starting point to come to my end of the field. I had to fly one mile to start running the mission. Ended up costing me three passes as I couldnt finish the other two at the end of the mission. This would be a big help to me to figure this part out, Thank you in advance.


Hi, any word on the KML based flight planning? It sounded like there was a test version I might be able to get access to?


Enabled for you now.

Hi guys, do you know if the multi-flight program is working properly now or the second flight is starting in the waypoint 1 after the first flight?

This should be working. If you notice it doesn’t recognize the point to continue the mission there is an option to adjust the starting waypoint so you can manually fix it.