Apps not showing up in 'All Apps' tab

I’ve installed and used the ‘KML and SHP Import’ app with no issues in the past, but for the last few days I’ve been unable to locate any of my installed apps or search for new ones via the desktop web browser version of Dronedeploy. When I click the ‘All Apps’ tab, whether I type a search query or not, I just end up with an infinite ‘Loading…’ message. When I click the ‘Installed’ tab, my previously installed app doesn’t show up.

I have attempted this process with several different computers and web browsers, and have the same experience with each computer.

Has anyone else experienced this issue?

I just tried selecting All Apps and on Firefox, it just says “loading…” until I disable my ad-blocker and then they show. On Edge, where I don’t have any plugins installed, they show right up. Try disabling all your browser plugins.

I always run Chrome Incognito.

Hi there,

Thank you for posting to the forum. Can you please ensure you are operating on the new view of our dashboard? Select Try New View in the upper right corner to switch. Our old dashboard will be removed in the near future, so you will want to make the transition.
If you are still having trouble accessing the KML app, please send us an email to so we can further investigate!


Hi Lindsey,

Oops, I hadn’t noticed the ‘Try New View’ button. Clicking it solved the problem!

Thank you for your response,