App crashes on start up android 12

Been using this app for work, making maps for solar fields. (I have a work account through a company for this). Last week my phone had a software update. I thought it was a standard bug fix and security update but instead it updated me to android 12. Drone Deploy, DJI go, aloft, and 2 other fly apps I use stopped working. All of them crash as soon as I launch them. Tap the icon, it pops up, and less then a second later I am looking at my home screen again. DJI go I got to work by downloading from their site and not the play store. Drone deploy does not seem to have this option and an attempt to contact them last week when this first happened has gone unanswered. So I am trying this. So DJI go works now (I have seen this being blamed jn the past for Drone deploy not working). I am on a samsung S21 pro. Been having to use my samsung galaxy tab A from 2017 with android 6 on it which has been a pain due to “limited Drone support”, incredibly slow response times and load times (5 minutes just to enter preflight checks sometimes). So I would very much so like to get this fixed.

Things that I have tried already:

Factory resetting phone
Uninstalling and reinstalling Drone deploy
Disabling, unstinstalling, force stopping android system web viewer
Getting DJI go to work (which it does)

Hopping this finally gets answered and someone has a fix for this. Or Drone deploy finally gets a fix for this soon.

1 Like

I am having the same problem. I have the business plan ($2,000 or $2,500 a year???) and it’s aggravating that there is not a tech support number I can call when problems arise.

You might try disabling Android System Webview.

Settings>Apps>All Apps (or something like that)

Our Androids had a similar problem but this was back when v10 came out.

As I said, I have tried force stoppeding, disableing, Uninstalling, and reinstalled an older version android system web viewer. Because I did see a previous issue with it. All of these had no effect on Drone Deploy starting.

1 Like

Sorry, I was trying to reply to temer91337.

I updated my phone just as you did. I haven’t had a flight since that update but I did get notified that DD had a new android update that was supposed to fix the problem I have had for 5 months. Are you using the newest update? I received an email from support about the DD update on 11/29/2021

I am using version 4.65.0, Google play does not say there is an update. And I keep unistalling and reinstalling to force an update if there was one. So it should be the latest version on the play store.

I did send an email from the site and have yet to receive a reply after 2 weeks of waiting.

1 Like

Wow. I just tried to open my DD app and it immediately crashes. Won’t even open? I’ve waited 5 months for a fix and am worse off now than before the update.


v4.65 is the latest. You’re the only one that actually stated what device they’re using and the s21 is not on the officially supported list. Their list does need to be updated though because the newest one they say is an s9. There is verbiage that says newer but if it has been that long that tells me that they probably have not tested Android recently. Along with that the s21, a21 and all of the other offshoots are not the hardware that typically comes in a standard release. There could be some other software on there conflicting. My Google pixel 5 is not officially supported but it works. Possibly because it is running a native version of Android 12 and not a 3rd party with whatever tweaks they have to it. I know a lot of people dislike Apple products as much as I do but I can tell you that they are near flawless on all flight solutions I have used. You can pick up a Wi-Fi only Mini 5 for less than $400.

I am starting the app before connecting anything. It opens and disappears from the screen but when you check the open apps (task view) it is actually still running. I can then click on it and open it just fine. I have used it on the latest android in this manner with the XT2. This is on a Samsung Tab S6 running Android 11. I only use android when doing the thermal missions with my M200. For everything else I am on my iPad Mini 5.

Interesting, I have not had that issue with it on 11. You are right though. When it dissappears and crashes on startup, it is still there in the task view. Clicking on it in the task view also instantly crashes on android 12 though.

We already know that Android 12 is definitely the culprit but it will end up being the responsibility of the 3rd party apps to adapt. Maybe it will affect enough apps that Google will issue a patch. Android and iOS both allow apps to run in the background after you have closed them but the mode they are in is different. Android is still using system resources so you normally have to force stop them or reboot your device. This is why it is a good idea to have a task killer on your system that effectively does this but at the touch of a button. Personally I use Advanced Task Manager. Android is nearly impossible to isolate issues like this unless you can read the code like looking at the debug mode in Chrome. You’d possibly have to look at several devices and figure out if it’s the same thing on every device. Every major manufacturer has their own flavor which actually doesn’t just look a little different but uses the system differently which is why my Pixel 5 still works.

Could someone try running in airplane mode and/or with GPS off to see what happens?

Hi @Eric_Davis, there is a known issue with Android 12 on Samsung S21 devices. DJI has informed us that this will be fixed in their next SDK update slated for the end of this year.

For all other devices, the latest version of DroneDeploy available in the Play Store (4.68.0) should not crash running Android 12.

any new updates on this problem
no reason to buy drone deploy if it does not work for me

1 Like

Not that I have seen yet. As said above they are waiting for DJI to release a new SDK at the end of the year. DJI go 4 does work for me though. So I honestly don’t know what is happening. I just got a vastking kingpad and been using it. Cheap tablet, sucks in sunlight, but has been working as a good backup until someone fixes something.

I just flew three missions this morning on an iPad Mini 5. All missions were different configurations Including multi battery, panel, video and progress. Google Pixel 5.

oh, i’m facing the same issue … :frowning:

Any updates to do after the first of the year it will help with the problem

1 Like

same issue.

Same here, android 12. All I can say is a business should not have dd as only mission planner. I will find another so I have a choice when the darn program won’t open suddenly.

1 Like