Problem with Drone Deploy IOS Beta on IOS 8

I have a iPad Air 2 that I have not upgraded to IOS 9, because I want to keep my Jailbreak (I use a few key features including screen record that are not available outside of my jailbreak.

I’ve got the Drone Deploy software on my tablet, but whenever I run it, it immediately crashes. When I run it on my phone, it seems to start fine.

Is there something on IOS 8 that prevents the software from working properly?

We’ve tested on iOS 8 and 9 in our offices. I’m not sure what could be causing the crashes. I haven’t experienced any in our office. Does this happen for any other apps?

All other apps worked fine.

Interesting, I fired up the app again and it worked this time… I might have rebooted the tablet since…

Two questions though:

  1. It’s showing my quad as “Eric’s Inspire”. I have an Inspire (might have run a mission with it previously), but now it’s connected to my P3. Shouldn’t it identify that?

  2. I selected the settings wheel in the bottom left and it brought up “choose map layer”, but it’s blank - no options.