I have a problem in my test. RTH?

I have a problem in my test. As the drone flew to the starting point, it immediately RTH every time.

1 Like

Hi there,
Thanks for writing into the forum.

I recommend ensuring your hardware is completely supported:

If you’re running an Android, I recommend ensuring you are on OS 12 for the best experience!


I think the problem is not with os or android because before that I can still use DD normally. I think this problem is caused by DD app having a problem, making it not usable if DD app always has this kind of problem. I can’t buy the app to use it. Please correct the problem. Thanks.

What device are you using? Have you tried a different device?

I am using android samsung j7 and galaxy tab a8 which previously worked normally. It just came in trouble the past few days

I assume you have uninstalled and reinstalled the app? Can you backup on of those devices, do a factory reset and reinstall just DroneDeploy?

all correct.
Now it can’t use the DD app as it used to. :thinking:

1 Like