Flight Plans have been changed?


I have several flights that I do on a regular basis and I noticed that my flights seem to have changed ? One particular flight shows it is half completed when I know for a fact that it was completed on the previous run.

One flight had a flight time of 14m40s and now shows it is only 11m12s. The start point has been modified and the plan doesn’t look as big.

Anyone got any ideas ? I’m a bit concerned that flights that I run regularly have changed plans.

EDIT looks like a difference between operating systems - IOS or Android
IOS flight plan

Android flight plan

Expected behaviour ? Different start point, different flight plan, different flight time - yet both loaded from my account.


It goes one step further. If I logon to DroneDeploy.com on a pc and check out the same flight it shows what the Android version shows - which is wrong.

So how can I get my flights to be consistent across all devices - tablets and PC’s ?

That is very frustrating to see. I was going to switch to a ipad and wondering if I am going to see some issues like this.

Hey guys, we are immediately fixing this bug. Sorry for the inconvenience. Hope to get this out in next released by end of next week.

When you say you are fixing this bug - how do you know which flight plan is the correct one ? I’d hate for my plans to change.

Any word on the fix ?

We are still trying to push the app – some other bugs have delayed our release. Will post here when we get a releasable candidate out.

Can you check the latest android release and let us know if you’re issue is resolved?

Nope - still showing different start point, different flight times :frowning: Not resolved.

I also completely uninstalled DD from the android device and reinstalled with no change.

Logging onto dronedeploy.com shows the same as the android…

We released iOS update a day later than Android. We don’t see the issue between latest iOS and Android. Can you check if thats still the case with latest iOS and android and if yes, send us the screenshots so we can see how much time difference there is.

I’m disappointed - my iOS plan now is the same as how the android plan looks and this was NEVER how the plan was when I started. I now have to reshuffle my plans to get them back on line.

So yes - you seem to have resolved the problem, but you have created a lot of overhead for me as I have to now verify all of my plans as being correct.

Original plan

Plan after iOS Update

As you can see the start point, flight path and flight time are now completely different to what I have been flying.

Further edit - ok I take it back - its not as bad as it seems. Looks like the overlap was affected and I can bring that back to what it was fairly easily. I’ll be flying this tomorrow using my android tablet and will feed back my experience.

Another edit I notice on both my iOS and Android devices that my offline maps display “waiting to download basemap” which never progresses.


  1. Attempted to fly with my Android Galaxy tab and my P4P. Couldnt get DD to recognise the drone was connected no matter what I tried. The controller had a green light on it and I could start engines - but DD just sat there asking me if I needed help on how to connect the drone.

  2. Resorted to my Iphone7. DD threw a weird waypoint error twice - which then cleared. Flight operated as normal. Back to the office and a run which normally has 300 pics only had 53. I checked my old flight plan and new flight plan and the front overlap is 60% which is what it should be. However it seems DD isnt firing the camera often enough.

Disappointing as I could always rely on my Iphone and now that isnt working correctly.

Fortunately I will not be flying for a month - so hopefully on my return the software will be sorted.