DroneDeploy Pre-v4.2 Lag/Freeze/Crash (Latest Interface)

Having to purchase a new iPad every time DD updates their app is a non-starter for me. Unfortunately, several missions I fly are through contracts that require me to use the DD app. I never had any real issues using the app prior to the Fall of 2019. But, it seems, these issues, along with the connectivity problems with the recent pano and video tool additions, have only become progressively worse. Maybe the air temperature is a factor?

Doug

2 Likes

Just wow…

Anyways, getting back to troubleshooting… Does anyone remember seeing this behavior before the new flight UI and new dashboard?

Hi Andrew

Yours is a common response to this type of problem. Those that have been at this awhile understand that new versions of the DJI SDK, and subsequently, new versions of a control app, like DD, tends to use more and more resources. We as users get it.

But to many (most) users, having the app work at the basic level, and work well, is 101% of why we use an app. So, when a new version of the app is introduced and folks update to it, and subsequently that basic functionality is compromised by … something. Even quite possibly a device that was close to it’s limits now can’t quite keep up. The logical solution is to use the last version of the app that has worked reliably.

Can DD make available a legacy app version simply to let users use the app with their current hardware as always? Of course you need not support it like the current version and it could come with a “caveats FAQ”, “At your own Risk” (We are used to doing things at our own risk !)

It would be nice if updating the app could be quickly reversed if the unexpected happens.
Maybe a feature in a new app version will entice someone to upgrade their hardware in order to get it. But if they don’t need that feature, they can work as usual.

3 Likes

Spot on D! This is an all-too-common problem in the mobile app and field technology worlds. It’s beyond me why developers aren’t required to keep an archive or repository available for instance like this. Imagine what it was like when I deployed 50 iPads in the field and the next Outlook update broke it…

2 Likes

I’m old enough to notice that new application development has changed quite a bit over the years. There is good, and there are bad aspects to this change.

One of the larger cons exactly relates to your comment, Michael. Developers USED to always have a fall-back version available. At the least, for a given amount of time after an update.

But it is not only in the version of android 10.in version 9 that we were using that is also happening to close the DD

1 Like

Yes, but in the summer it pays, thanks to you that all riders choose to pay only one.

2 Likes

There are several capable flight softwares that are free and a few others that are less than $30 so I am not sure I quite understand the problem. You can upload photos taken on any drone that correctly geotags them agnostic to flight software. Near half of my flights now are on DataPilot with a Yuneec H520 so DroneDeploy flight doesn’t even come into play.

Still not a solution? It’s time to find it, right?

2 Likes

Don’t have any updates here.

Update to version 4.0 downloaded and testing. So far working perfectly.

2 Likes

Using DD v4.0 android (S10E SMG9700, android 10) flew MPP (current fw/sw), and experienced several DD crash/restarts across multiple flights. Thought this was supposed to have been fixed?

2 Likes

Not officially resolved. Some users have been able to get better performance by making sure that all other apps are closed. I myself always turn off WiFi. Unfortunately the other option is to get a device with more horsepower. We as users are doing what we can and will be keeping this forum updated, but for now consider the issue still live and being sorted.

Hi everyone.

I’m Sander from Brazil (Araxá/MG) and I’m having the same problems of @LabellaRVA, @Maverick and others.

In addition to mapping activities, I do photographic monitoring of a site work for over a year once a week. I follow the same flight route since the beginning of the work.

Does anyone knows if I delete the app I will lose the flight plans?

I’m running the app (Drone Deploy 4.1.0) on a iPad Mini 4 13.3 iOS and it is a Phantom 4 PRO

1 Like

Log into your account online. If all of your plans are there they are not app dependant and will import back to your device if you reinstall.

2 Likes

Still having problems. Last Monday I flew some stockpiles at a pulp mill, about 145 acres in all, and the app kept freezing. Although the drone flew the mission normally, it was a bit unnerving not to be able see the progress or the amount of battery left.

Another quirk was as it was finishing up the mission it flew home twice and landed. The app did not seem to want to finish the entire mission, saying that I needed to continue. So I sent it back to “finish” and it flew back to the location a continued for a few seconds, then flew back home. Again, the app wanted to continue, but I ended it there. It seems all required photos were taken.

I’ve flown these exact missions before without the app totally freezing up. And it seems to be gradually getting worse.

Doug

P4P (latest firmware), DD app 4.1.0, iPad 4 Mini, iOS 13.3.

1 Like

Just keeping a running tally. We have intermittent lagging, continual lagging, solid freezing and crashing.

How about intermittent freezing? Is anyone experiencing a decent length freeze and had the app return to working order before the flight was up?

Yes. I’ve had some intermittent instances, but the progress map never came back to live. Always have the FPV screen, although very choppy lately.

2 Likes

Hi. Same here. I switched to Android device and it worked perfect. I usually fly with an iPad.

2 Likes

iPad 5th generation
iOS 13.3

1 Like