Feedback v1.2.0 and P3Advanced

I would like to give some feedback to the v1.2.0 using DJI P3Advanced and Samsung Galaxy Note 8.0. I did a couple of short mission of 3-6 minutes.

Some problems:

  • I had problems connecting the app, when first using DJI Pilot (to make necessary settings). I always had to kill all apps and wait some time, until Android would really stop the app.
  • I also had to reconnect the USB cable and select the DD app from the suggested options, otherwise it wouldn’t detect the RC.
  • The DD-app was crashing sometimes after the flights. Sadly I couldn’t replicate it.
  • After one crash, the drone was still taking images, obviously DD didn’t tell it to stop. When I switched to the DJI Pilot app, the camera sound was clicking, but I couldn’t stop it. Had to turn the drone off and on again.
  • For some reasons, after each flight, the message said “1 picture” taken. Which was obviously not true. Same online in the overview.
  • The pre-flight checklist has some graphical glitches (shaky rectangle partly overlaying the checklist, showing some part of the background-map).

Some questions:

  • Why is the drone flying away first? It was really confusing at first to see it fly away in the wrong direction.

Some general feedback:

  • It was awesome to see the drone fly away autonomously. As soon as all checks were done and it was ready to fly, everything was going perfectly well and easy. Thanks for that! :wink:

Hope that helps somehow,

  • plitvicer

PS: Sorry for my bad English, I’m from Germany.

Thanks for reaching out!

Unfortunately due to the USB connection, the both the DroneDeploy and DJI GO app will crash if one of the other ones is currently running. This is unfortunately outside of our control.

Sorry to hear the app was crashing - I’ll look through our logs to see what might have caused this, and see if we can perhaps find a resolution for it.

Regarding the 1 image taken issue - Unfortunately using the P3 Advanced and Professional have different camera libraries, as we need to do some extra work to get accurate image counts off the Advanced - we’re just focused on resolving the current firmware issues first.
That means it will continue to say 1 image captured until we get that functionality, but it should still capture all the images, and if you use the auto-uploader, it should select all the images captured during the mission. If it’s only selecting the one image, then please switch to the Manual uploader and select the entire image set. Thanks for being patient and understanding!

Regarding your question of the drone flying away first - I’d love to understand what you mean by that!

Great to hear you enjoyed the autonomy - it’s very exciting to be able to create these on-demand digital snapshots of the world around us!


Thanks for the opportunity to use the Inspire 1 beta, I completed my first mission this morning with no major problems at all, congratulations to you guys on getting this great product up and running.
I thought I would provide some feedback to help iron out any bugs;

Tablet: Nvidia Shield LTE on Lollipop 5.1.1 (tablet is rooted, I noticed in the system requirements that it says support for Lollipop is comming soon-worked fine for me in Lollipop)
Drone Deploy Beta app ver. 1.2.0
Inspire 1 aircraft firmware
Inspire controller firmware
Data via LTE
SD card Scan disk extreme pro 32gb

On start.
Setup Inspire and carried out compass calibration using DJI GO.
Closed DJI GO in app manager and opened Drone Deploy.
Expected: I expected DD to open and hookup to the Inspire
Actual:Would not connect to Inspire.
Closed App and Rebooted controller tried again
Expected: I expected DD to open and connect to the Inspire
Actual: Did open did connect to Inspire but seemed to stop responding in preparing flight (status circle just kept going round and round for too long).
Closed App turned off WIFI data and checked LTE enabled (I wasn’t sure if it was trying to hook up to a public WIFI like BT fon, in which case the app would only get the login page for the public wifi access and not the www).
Restarted app and this time it all worked fine, pressed take off and Inspire lifted to hover, gear up then offset 5-10 meters away (SW) from home point, then returned to ontop home point and then went in to its planned flight path, carried out mission with no problem.

I was in a bit of a rush this morning so my notes are not as comprehensive as I would like, I will try to get more specific data next time, thanks again.



Ok, I’ll try to explain again the issue of the drone flying away first: The image below shows one of the test-flight logs. The two white lines far right show the issue. It was not a planned flight path, but the drone flew away and then came back to start the planned paths.


This was similar in all of the short flights I did. Is it on purpose?


  • plitvicer

Thanks for the feedback @Airlens and @plitvicer.

The drone should not be deviating from it’s current position when it initially starts. If this happens again to you - could you notice if it’s perhaps drifting with the wind? We have seen some situations where the drone isn’t maintaining it’s position hold, and instead gets carried away by the wind. After a few seconds, it returns to the position hold, and goes back to it’s intended position.

Please let me know if this is the behaviour you’re experiencing. If not - it would be great to get the DJI flight logs sent across to

@Airlens - sorry about the startup issues. In the future, could you try unplugging and replugging in the USB cable between GO and DD? Please let me know if this resolves the problem.

Jono Hi,

I tried another mission last night for our local council to map a lake reed bed, I was quite restricted on the space and once again had only a few issues of rebooting the controller and app but go it all ready without too much fuss.
It did however drift again and as you say it did drift with the wind direction of the day, I will confirm if this is the case when the wind direction changes (it is E at the moment and prevailing is SW).
On this mission I had more waypoints than the fisrt (about 30 in total, 24 on first mission), due to the drift I had to cancel as I would have broken the limits on my Permit. I would say that it is drifting while it uploads/sets the waypoints, my logic for this is because when there were fewer waypoints it drifted less than when there were more. As it had drifted to far for comfort I switched from F to P mode and recovered the drone manually with the controller. The App then confirmed that the waypoints had failed to load so I’m pretty sure it is drifting whilst it loads the waypoints.



We’ll be releasing an update in the next day or two which should resolve this.

Thanks for your patience!