Waypoint upload Failure

Summary of Issue:

Waypoint fails to uploadimage

Date Issue Began: today

Drone Model: m600

Mobile Device Model and OS version:
iPhone 6 and Samsung s8

DroneDeploy App Version:

Currently in the field wasting valuable time. Have a call out to Eric Povero and Andy Putch.

Call me ASAP

Hi @ZDudek,

I would suggest uninstalling and reinstalling the app again (if you are connected to cellular or wifi to re-download it) and also turning the mobile device off and back on to clear out possible conflicts. Is the USB connection between your device and drone remote controller secure? Hope this helps!


Changing the direction of the flight plan by a few degrees often solves this.

Also, try copying the map or redrawing a new one.

I also had the same problem. I tried to fly twice with P4Pro on July 7, 2018, flights “Engineering - H = 30 m” and “Faz. Areão - H = 80 m” (login: droneviewandmaps@gmail.com). Both times the pre-flight checks were done with “OK” in permissions, drone, camera and controller. However, when the fligth plan was checked, the message appeared “Error loading waypoints: The info of waypoint mission is not completely uploaded - Replan or Retry” appeared. I tried to restart the process several times and even copied the plan, but I did not succeed. I canceled the flight with DroneDeploy and had to fly with Pix4DCapture, in which I succeeded. What could be happening because I even checked if my smartphone was compatible with DroneDeploy … is there any procedure to fix this?

Hi @DroneView_Maps,

Sorry to hear you encountered a waypoint checklist error. I checked your mobile logs and noticed that you are a couple versions behind on the app. Please uninstall and reinstall the DroneDeploy app to ensure you are running the most up-to-date release. For your reference, we are on V.2.76.0 and you were running V.2.74.0.

One other thing to note is that we do not officially support your Android device (Galaxy A5 2017), so we can’t guarantee that DroneDeploy will work as intended without issues on your device. Please take a look at our page of Supported Devices - we encourage you to use a supported device from this page and see if the issue resolves itself.