Waypoint Upload failing

@kara Sorry while I’m at it - do you know if the tech team is looking into fixing the focus/camera settings issue? It would be ideal to be able to fly up to waypoint height, then hover and adjust your camera settings, then proceed with the mission, instead of constantly having to restart controller or unplug phone to keep switching between apps - which should enable you to control everything all from within the one app?

Hi, as far as switching apps, I don’t think it’ll be possible for Android until DJI is able to improve the android connection. It’s not something that they’re going to be able to implement yet. The good thing is the drone industry is iterating quickly and technology is improving year over year. Sorry I can’t be of any more help on this in the present moment.

I am new to DD, can anyone tell me what the broken dotted line means on the map overlay, (Flight Path)?

Dotted lines are where you have flown already or if you change the starting point it acts like you already flew that area.

Thanks, will it affect the next flight or can I clear that from the system? I have only been creating simulated missions to learn how it works, haven’t done any flight yet, cant get my android tablet to connect to my DJI 2.4Ghz Data link. I may have to switch to IOS…ugh!

When you go to start the mission have it start from the beginning…it should be a slider that can go back n forth. So you will see the dotted lines appear and disappear.

For you connectivity issues will it not connect to the drone period? Try uninstalling the application and reinstalling then restart the tablet. I have had to do that with a few different apps trying to connect to my drone. Also Pix4d Capture caused everything not to connect so I just have to uninstall that app completely and not use it.

Make sure DJI GO app is not running in the background as well.

Great, thank you very much for the help, I’ll try all of that.

Cool, post if it works or not.

1 Like

I confirm, I have the same problem, Phantom 4

1 Like

Update: With current iOS, app, and DJI firmware for the Mavic as of 4/28/17, I successfully flew a 277 acre test mission yesterday. So things are getting better, thanks for that DD team!

1 Like

The dotted line is where the drone is going to fly from it’s takeoff location to the starting waypoint.

Thanks for the reply Kara.

My main problems with DD are as follows (copy and paste from an issue I posted about today):

Hello, I’ve been trying to execute a map I’ve created with DD with no success at all. I’m using the DJI Mavic with the latest FW update, and the current app update (as of 30th April 2017), and the phones in using are Galaxy S7 Edge (Nougat) and Galaxy Note 5.

The map itself is around 100Ha (240 Acre), it has around 215 waypoints. I’ve saved the map as an offline map, for some reason this was the only way I could get the mission to start, as DD just sat there hanging last time and kept saying "waypoints haven’t finished uploading to drone etc. I sat there and waited half an hour and still nothing.

Today I went back out and tried again with the offline map. It did all the pre-flight checks and was good to go. So I hit 'Fly, the bird took off to the set altitude, then crawled over to The 1st waypoint. But on the way there, it decided to tilt the camera back up to the horizon (after I had already set the manual camera settings in the Go app before switching over to DD), and I couldn’t tilt the camera back down. It would go about 1/3 of the way down and then keep bouncing straight back up to horizon. After it got to waypoint 1 and started the mission, no photos were being taken either. Another thing is that it seems only about a third of the waypoints were shown on DD. I read in another forum somewhere that DD has a waypoint limit? I fail to see why this would be, as they tout how “easy” it is to do multiple battery missions for larger areas.

I have followed DD’s instructions for larger maps to the letter, and can’t seem to be able to get this bloody map done! It was embarrassing when I tried at first because the paying customers were there with me, only to see failure.

I have also tried with DJI UltimateFlight app where I imported a waypoint .csv file. It created the map just fine, but as soon as I tried to take off it told me “maximum number of waypoints limit has been reached” and it failed to upload.

I am now going to try to get my CSV Points over to Litchi and see if that will let me fly the map. If not then I don’t know what else I can do. Starting to my tear my hair out.

Your beta app says that the gimbal pointing forward issue has been fixed, but clearly has not…

If anyone knows of any other MP / capture app with no limits or restrictions that can actually create and execute maps then that would be great. Cheers guys.

1 Like

Put it this way - I have never once been able to execute any map of any size using DroneDeploy. I’ve always had to use Pix4D Capture. Which is great if you only want to draw a general box around the area to be mapped. But useless for a shaped map as there us no polygon tool…

1 Like

We’re investigating if there is an issue with larger maps. There should not be any waypoint limit. I’ll let you know when a fix is out. Sorry you’re having trouble.

I’ve now got the quirks on my P4 sorted out. Today I went out with my P3 to fly an area I have flown before.

Switch is in F position, all checks are complete, but when I hit the fly button it says “The waypoint uploading is not complete”.

This flight used to work. I have flown it on multiple occasions.

I expect that this will get fixed and a new version of DD will be released - but I guess I question - what will be broken then ?

Your software is awesome when it works - but I think that every new release has new bugs that I have to spend flights working out what they are and how to work around them.

Using an android tablet. It might be different on apple but the version on that platform has camera issues that I dont think have been resolved yet.

Please let me know when the fix is implemented.

1 Like

Hi syamaphantom,

Sorry to hear that you are experiencing issues with your Android. I have listed a few things below that usually alleviate these types of issues:

  1. Making sure your P3 is running the latest firmware.
  2. Power cycle your P3 and mobile device.

We do have a big release coming next week for issues that are being experienced with the Android. Keep a look out early next week for the new version.

Thank you,

I have confirmed that the P3 is running the latest firmware and I have tried power cycling both the bird and the tablet and retrying to get the way points to upload several times to no avail.

This is obviously a bug in DD’s software so the suggestions are not really valid. The bug should be acknowledged by DD and a fix put in place.

1 Like

Hi Chase,

How are you guys going? Have you figured out the problem with your software and fixed it yet?

My drone is still grounded and paying customers still waiting because of an app.

I’m still getting the same message saying “waypoint uploading is not complete”.

I have redone some maps so that they are less than the set 99 waypoint limit and still makes no difference.

I did manage however to get a test map at home started earlier today - it uploaded 2/3 of the waypoints (presumably only enough for one battery), but on the 1st leg of the waypoints, the camera just jerked up to horizon and stopped taking photos, again, and wouldn’t let me manually tilt the camera back down.

Come on guys, please get this issue addressed. I was hoping to upgrade to your Pro subscription, but if I can’t even get a simple map done on the basic sub then yeah, you know where I’m goin…


1 Like

Please let us know if the new release 2.0.44 helps.


I’m suffering the same problems everyone else on here seems to be having. I get the Waypoint upload and Controller position problems on every flight I’ve tried in recent weeks. I haven’t been able to get my drone in the air once with this app. Flying a Phantom 3 4k with iPad (also tried two different iPhones, both with the same results- or lack thereof).

Today alone I tried to fly a 40-acre tract, bumping it down to 20, and finally to 10 acres just to see if the app was just being slow to load. I let it wait for about 15 minutes on all attempts and nothing happened. Controller is in the F-position, I’ve power cycled controller, app, phone, and drone at least twice prior every acre attempt, as well as re-installed the app twice now. Nothing is working. Would be very appreciative of any help.


1 Like