Waypoint limit exceeded? Camera tilt not working also

Hello, I’ve been trying to execute a map I’ve created with DD with no success at all. I’m using the DJI Mavic with the latest FW update, and the current app update (as of 30th April 2017), and the phones in using are Galaxy S7 Edge (Nougat) and Galaxy Note 5.

The map itself is around 100Ha (240 Acre), it has around 215 waypoints. I’ve saved the map as an offline map, for some reason this was the only way I could get the mission to start, as DD just sat there hanging last time and kept saying "waypoints haven’t finished uploading to drone etc. I sat there and waited half an hour and still nothing.

Today I went back out and tried again with the offline map. It did all the pre-flight checks and was good to go. So I hit 'Fly, the bird took off to the set altitude, then crawled over to The 1st waypoint. But on the way there, it decided to tilt the camera back up to the horizon (after I had already set the manual camera settings in the Go app before switching over to DD), and I couldn’t tilt the camera back down. It would go about 1/3 of the way down and then keep bouncing straight back up to horizon. After it got to waypoint 1 and started the mission, no photos were being taken either. Another thing is that it seems only about a third of the waypoints were shown on DD. I read in another forum somewhere that DD has a waypoint limit? I fail to see why this would be, as they tout how “easy” it is to do multiple battery missions for larger areas.

I have followed DD’s instructions for larger maps to the letter, and can’t seem to be able to get this bloody map done! It was embarrassing when I tried at first because the paying customers were there with me, only to see failure.

I have also tried with DJI UltimateFlight app where I imported a waypoint .csv file. It created the map just fine, but as soon as I tried to take off it told me “maximum number of waypoints limit has been reached” and it failed to upload.

I am now going to try to get my CSV Points over to Litchi and see if that will let me fly the map. If not then I don’t know what else I can do. Starting to my tear my hair out.

If anyone knows of any other MP / capture app with no limits or restrictions that can actually create and execute maps then that would be great. Cheers guys.

Give Maps Made Easy a look for flying.

I believe there is a limit for waypoints in the DJI software for the drone. I’ve experienced the same thing on different apps. The bird must only have enough processing power for a limited amount of waypoints.

Yeah I had a look at maps made easy but I’m Android and they aren’t looking to support is anytime soon. It does look like the best solution, but I don’t wanna have to buy an iOS device specially for one app if I can avoid it…

It makes no sense that DJI would have a waypoint limit in their software - it’s just basic CSV text. And considering DD say their app is suited to Phantom, Mavic and Inspire, and they also advertise it can do multiple battery missions for larger maps. You would think DD would actually test in real world the capability of each kind of drone with their app before they release and say that it’s good to go…