V5.3 Bugs and Feedback

Thanks for trying v5.3!

Please add feedback and bug reports as a reply to this topic.


Flew a large area today with the new 5.3 release. Wanted to see how the continue mission feature would work. Picked a large area (around 200 acres) of crop land to cover. Started the first leg of the mission and everything went well. Battery got down to the point where the software brought it back to the home point. I noticed on the way back that the pause button would not stay active. I had to keep pressing it to keep it activated. Landed the drone shut everything down and then restarted everything selected the old mission and went through the checks. The drone took off and picked up where it left off just like it was supposed to. Let this leg go until the battery hit the point where it returned to the home point. When it came back and landed the mission ended and said downloading image 1 of 1. This got me concerned because there should have been around 170 images for this leg of the mission. So I pulled the card and realized what had happened. The card that I was using had some older images on it and the Phantom created a second folder 101MEDIA for images. The only image from the second leg of the mission was the initial image of the ground that is taken during the checks. So I got a empty card and put it in to finish the mission. Started everything up and it flew the last part with no problem and the images where there. Here are the issues that I ran into for this mission:

  1. The app needs to ask you what altitude you want when you set the mission up. I keep forgetting to check the settings and I flew this one at 328 instead of 390 like I would have liked to.
  2. The drone is still capturing images on the way back to the home point if you do not hit the home on the app. After the first leg it took images all the way back.
  3. There needs to be someway to verify that the camera is capturing images during the mission.
  4. Now that I have images on two cards the upload will not work.

Thank you.


Ah. I didn’t think about the case where it is low on battery and comes back that it needs to stop the camera. I’ll add this to the list.

I’m thinking of ways to better indicate which altitude the aircraft is going to fly at without blocking more of the screen during planning.

If you upload from each SD card it should be fine. The image count will get set to whatever you uploaded last but it should just be appending to the list of total images on the servers.

We don’t have a much better way to determine that the camera has started. We tell the DJI to start capturing images, and we continue to tell it to start the camera in case something is wrong. In the logs we see that the camera successfully started capturing for each of your flights. DJI has suggested to keep track of the remaining images available on the SD card, but this currently causes the SDK to crash.

I have tried selecting the the directories to upload from but it will not work. Can you set it to manual so I can put the images I took up. Thank you.

What do you see when selecting the directories? Underneath the error message there should be a way to open the old uploader if you need it. That got added yesterday.

Could not find any files matching this flight. Select a different directory./h4>
Having trouble? Use our older uploader to select files manually.

This is what I get. I see where to use the manual uploader. Thank you.

using lg g3 app crash after two minuts without any conection yet

Are you able to first test your connection to the drone with the DJI Pilot app and then make sure to fully close the DJI pilot app and then open DroneDeploy. They can’t be open together.

no conection with my pilot also i will buy new cell to use since im using the ipad for the inspire and the lg g3 will not work with pilot

I was able to connect DroneDeploy to my Inspire and began building a mission. Unfortunately during the Pre-Flight check I kept receiving the same error instructing to change the mode to either A or F but I could not get this error resolved. Also once the preflight has failed how are we supposed to refresh the screen. When I get the mode error pop-up box I’d have to hit the back button on my tablet which would bring up the mission planner with the failed pre-flight check list but there was no way to refresh this screen. At this point I’d have to kill the program and open Dronedeploy again. By reopening DroneDeploy I experimented with every combination (i.e. opening the program while in P mode, then switching to A (even at other times I tried F mode) before attempting the pre-flight check (even tried opening DroneDeploy in A & F mode then switching to P or just leaving the controller in P, A & F mode) but every combination came back with the same failure.

The error will disappear once the issue has been resolved for the A/F mode. New versions of the firmware require F mode, some of the older ones require A mode.

This error is another possible symptom of not having the correct firmware version. Have you upgraded the firmware on your inspire, or do you know which version of the firmware you’re running on?