V10 (1.1.0) Bugs and Feedback

Chase, I’m not able to move forward. Latest firmware installed 1.04 - 1.1 Downloaded from the google store.

Error: Failure to validate against server please restart app. I’m not able to get any further.

I am connected to the internet. Everything works with the previous app besides hanging at mission. Both version are presently installed. But… I did log out of the previous version.

Any suggestions?

Chase and I emailed about this but thought I would pass this on in the event someone comes across it.

Updated FW (whatever) on the Inspire after having some of the same problems everyone else was having. Also got the updated 1.1.0 app and went out late yesterday to do some tests. Two test completed without problem and yes, I like the rounded corners and camera pointing forward until off the ground.

Got up this morning to go shoot a project for a client and set up everything nicely. Activated the Inspire, remote and then . . . .the remote started showing a red light and constant beep. Shut down remove, powered on again and same thing. I went ahead and connected my phone and signed into DD, made the connection, set my flight plan and decided to press the check system status (green aircraft icon). System checked everything OK and said I was ready to take off. I thought about it for a minute and decided to press the take off button ready to take the drone back over at any moment but the Inspire did its normal thing, rose, halted, adjusted camera, lifter landing gear, climbed to proper height and proceeded to map a wonderful work product for my client. Weird but when I came in for a landing (I never let it land itself; I always take on that job myself) I moved the flight mode from F to P and the beeping from the controller stopped.

Got home, downloaded my data, went out for another shoot to check the remote controller issue but never got off the ground. Could never connect. I kept getting this error . . .

Initialization Failed: Failed to validate against server. Check internet connection and re-launch app.

Internet connect strong. Restarted my phone to reset it in case that was the problem, tried again and same thing. Came home and attempted to connect via my home wifi (very strong) and same thing.


Sorry Chase, I see you are already on it. Thanks.


The validate against server needs a good connection because DJI’s SDK times out after a really short time. After the initial validation it shouldn’t be as difficult.

I will look into the error a bit more to see if we can do more to prevent it.

I will continue to try on hold my tongue right in-between power cycles. My connection is good and tested prior via chrome.

Thanks for the response. I will provide an update if I’m successful.

Any luck SkyBox? I changed monitor devices and still got the same thing.

I think it’s dji side. I’ll check.

Yup. Same glitch in the Matrix. No luck.

Ah, the beeping while it is landing is letting you know it is coming in for a landing.

No, the beep while landing comes from the monitor device. The beeping is coming from the RC controller before take-off and during the entire flight until I switch flight mode to “P” to land manually.

OK, thanks. I’ve tried on my Samsung Galaxy Tab Pro (keeps crashing), my Samsung Galaxy S4 phone (was working until the “failed to validate” thing started out of the blue this afternoon, and tried a Samsung Galaxy Note 2 (got the “failed to validate” thing. Chase will figure it out.


We’re having issues now with Drone Deploy not connecting to the Phantom 3 Pro. We are on the latest firmware FW_V01.04.0001 using DD v10 and latest DJI Pro.

Had no issues until today, now the app either hangs and never connects or errors: “Failed to validate against server. Check internet connection and relaunch app” - have checked connection and it’s fine, tested on both 4G and WiFi with same results.


We’ve seen that a lot today. We think it has something to do with the DJI server it is validating against. Checking this right now.

Go Chase GO!!! You are the MAN!!!

Hey Dale, can you try completely uninstalling the app and then installing the beta from the play store?

Or can anybody else try that? I think a version we had on the store earlier today might have had an issue with our SDK key.

It does appear to be a problem with the DJI response when validating the SDK. Try uninstalling and reinstalling. I have an idea that I can try to release tomorrow to avoid this in the future. Let me know if you get it working.

I already tried that but it was a couple of hours ago. Do you want me to try it again?

No that’s ok. I emailed our contact at DJI so hopefully we hear something back about whether we can fix it on our side. I have an idea for tomorrow though.