V10 (1.1.0) Bugs and Feedback

Thanks for trying V10 (1.1.0)!

Please add feedback and bug reports as a reply to this topic.


Are the Firmware Update procedures for Aircraft and RC the same as before?

Didn’t see anything in the Release Notes but were any of the issues with the Continue Mission addressed in this version?


We updated to V10 (1.1.0) APK for Inspire 1 and Firmware (MobileSDK/WM610_FW_V01.04.00.01.bin5) using normal update procedures. The software installed for us without any issues. We have bench-tested the software & aircraft this morning and it went through the flight test checklist properly and indicated takeoff (we visually confirmed motors started) then shutdown as expected since we were bench-testing without propellers on the aircraft and it know to turn off.

We are experiencing rain in Atlanta, GA, USA today but will try to get an actual flight in at the end of the day, weather permitting. Just wanted to let you know the new APK & firmware appear to be functional for us.

Also wanted to thank you for all the work you guys have done to get us back up and flying again with this new software. We really appreciate you as we couldn’t provide mapping since the DJI mess.

FYI, we notice that the APK places two DroneDeploy icons on our Android during installation. We thought that it was because we didn’t uninstall the old one but we have since uninstalled all DD apps and reinstalled the current one several times and we still get two apps appearing. Not sure why that is happening but everything works and thought we would mention it.

the two Dronedeploy icons are interesting. I saw this too but thought it was another version we had. I’ll look into it today.

The continue mission improvements should come with offline planning and flights in the next update. That is because we will have better syncing between our servers and when a user flies so it should always go to the correct waypoint.

Today I’ve flown my first mission with V10(1.1.0)
The fact that the camera doesn’t point down when the Phantom is on the ground is very useful for camera safety.

The “rounded corners” in the mission route seem to save some flight time.

And although it was some wind blowing, the Phantom has flown perfectly aligned with the route

The flight is https://www.dronedeploy.com/app/data?planId=55d45b182b13753cdf525039

Keep the good work!

1 Like

Later I’ve flown my second mission with V10(1.1.0)
One strange thing I have seen is that after takeoff, the Phantom stays hovering for some seconds. But first it hovers at 1m height and while hovering it descends a bit, nearly touching ground.
It is not a bigt problem, only a bit scary, but if the wind is strong the drone can crash.

We will do some tests here to see if we can decrease the hovering. We had to adjust the way we takeoff quite a bit.

I saw your maps that you submitted. Were those taken when it was dark?

It was late here, and maybe I adjusted the camera in the wrong way, because the resulting pictures are worse than I expected

Updated the firmware on the Phantom and the Drone Deploy app today with no issues. After the update I flew with the DJI Go app with no issues and took a few images. I then closed it out and started Drone Deploy with no issues. After I connected I loaded an old mission to refly an area. I adjusted the height setting to 350 feet and toggled the use auto settings off to see what it would say and then I toggled it back on. Started the mission and the drone flew with no issues. I like the new changes with the camera rotation, hover, and it turns on the end of the paths much faster than before. After this mission I went and flew another field with a new mission and this time I setup the camera in manual mode in the DJI app to see how the images would look. When I got back to upload the images I saw that the images for the first mission are very very dark but the initial image before take off looked good (it is below). The images from the second mission with the manual settings look good. Do you have any reason why the initial image looked good but the images of the field are very dark? Thank you.

I’m not sure why the first flight looks dark. We’ve always had an issue with a small percentage of flights using the auto settings. If you’re comfortable setting up the camera for your flight before you make a map I think you will probably get good results every time. We’re trying to find the best auto settings so people get a pretty good map without any effort.

Thank you. Is there a way to see what the camera settings were when the image is finished so I can know which settings work the best. Thank you.

Echoing Davet01, I just bench-tested the Inspire 1 running 1.4 and v10 DD - everything checked off and take off was initiated. I will be field-testing this Friday and will let you know.

Keep up the good work!

Updated my Inspire 1 to the latest Beta firmware and updated to the current build for DroneDeploy. Everything went flawless during the flight. The only thing I am unsure about is the way it transitions from one grid line to another. with the rounded cornering it seems to be a little jerky and I think the stop and turn worked better with the images it captured to make sure you had one at the end of each line. I also seen a post that mentioned the flying forward only. I hope you do not change this function as I seem to be having issues with another app processing the data correct and the only difference I can see between your app and the other is the flying forward. please keep it this way. GREAT JOB ON THE APP and I look forward to future releases.

I just uninstalled the previous version and installed 1.1.0 but i see 2 DroneDeploy icon aswell. One icon is not working and can’t remove it.

Yes we noticed that too. Was a mistake caused by the new way the app needs to open with the new sdk. It has been fixed now and the next version you download won’t have two. You can only remove the primary icon and it will remove both. Sorry.

asus memopad 7 me572c aka k007

will not launch.
‘unfortunately, donedeploy beta has stopped’
so frustrating. no other apps running to interfere.
tablet runs fine. lollipop.

Same here but as the new version was automatically uploaded by google play, I figured it kept the old version. On my Tab 6 the new version shows up as Drone Deploy Beta

I have run 4 missions this morning. Data uploading now. Everything went smoothly and worked as it should. A few suggestions on the new version. The transition is helpful and having the camera point away from the ground is great. Is it possible to have the takeoff transition occur at a higher altitude? Having it transition while still at eye level, the AC is still in ground effect and has not yet really had a chance to GPS stabilize so for me at least it has wandered a little while stabilizing. 2nd, is it possible to have the aircraft fly to and return from a mission at a much faster rate? As mentioned in another post, the aircraft uses battery power pretty quick while moving at such a slow pace.

Keep up the great work guys!

Saw your bug report. Trying to look into it.