Using DroneDeploy with DJI CrystalSky 7.85 tablet

I’m flying a DJI Inspire 2 with the X5S camera. My FPV display is a DJI CrystalSky 7.85 Android tablet. Has anyone been able to get DroneDeploy to work with the CrystalSky tablet?
This tablet is running Android version 5.1 and it is locked down so you can’t install 3rd party apps. The tablet does not have Google Play services installed, which is required to install any app from the play store.

I’ve tried a couple of times downloading the Android .APK install files for Google Play services, GoogleMaps and DroneDeploy from the apkpure website. Using the ADB command line program, I can get everything installed on my CrystalSky, but when I try to run DroneDeploy is says it requires Google play services, which is not running. I’ve tried various versions of Google and DroneDeploy without success. I’ve contacted DJI and they said that the CrystalSky does not support any app that has a cost. Only free apps can be installed and these are limited.

I have found various links with instructions on how to root the CrystalSky so you can bypass the install restrictions. I have not been brave enough to try these yet and risk bricking my tablet.

I have been able to install Pix4DCapture, which works very well, but it is very basic. Pix4D seem to try and make you do all the processing with their cloud apps, so they don’t put a lot of functionality into Pix4DCapture. I would much rather use DroneDeploy if I could. Any help would be greatly appreciated.

Hi @jfranklyn,

We currently do not officially support this setup so there’s no guarantee that it will or should work without issue. For your reference, here’s a page of our Supported Drones and Supported Devices (Mobile and Tablet).


After installing Google Play services apk file from apknite, apkpure,… did you sign in yet?

I was never able to get Google working on the crystal sky. I sold it and bought an iPad pro 11". Much more reliable and useable.