Use DJI Phantom 3 4K with issues taking photos in DD app

Using DJI Phantom 3 4K that will fly the DD route, but not take photos. We have been attempting to use the camera settings from the DJI Go app, but there is very little documentation on how to use it in conjunction with the DD app. I am using an LG V30 phone as the device. We were able to do a single successful 3D mapping of a 5 acre property but using only the DD app. The issue there was the DD app has a terrible auto selection for ISO and shutter speed. The drone ran that route at 35mph, and used a shutter speed of 1/35, which is horribly too slow for something moving at that speed. The result was very blurry photos. That is why today we attempted to use the settign to allow DD to use the DJI Go camera settings.

We are a company that does software engineering on a large scale, and to be honest, the Android version of this app is very buggy. It could be the drone platform is old, but the app does not connect reliably, nor have persistent repeatable errors. Obviously, those are the worst kind of bugs because they are hard to track down.

The bottom line is, can someone explain HOW to run the DJI Go app adn the DD app together so we can use the manual shutter speed settings in the DJI Go app?

We will give this one more shot today with the DJI Go app killed , and turn off the “Set Exposure Manually in DJI Go” setting in the DD app and will provide the results in this issue (weather pending because we are experiencing Florida afternoon thunderstorms right now).


So, just to provide the update I said, we went out and flew another mission, with the DJI App completely killed, the “Set Exposure Manually in DJI Go” set to off and flew the mission. We also formatted the SD card prior to killing the DJI Go app. The results of the mission were the same. It flew the route exactly as designed, but did not take a single photo. There was a single photo on the SD that we had manually shot. We also had a camera view from the drone as it flew, so the camera was functioning, it just took no photos. At this point we are putting this project on hold until our developers write a flight app for Android that is a bit more reliable.

The issue began today 8/10/2018

Drone Model:

LG V30 running Android 8.0.0 released June 1, 2018

DD App version 2.77.0

DJI Go App version 3.1.43

The Phantom 3 4K is not one of the primary drones used by DD customers so it is not in the test circuit as described here.
It may have difficulties. A Phantom 4 Pro would be a much better drone for this with it’s mechanical shutter. The software has worked fine with that drone (and other supported ones) for hundreds of customers.

You cannot fly with both apps open at the same time since it only allows one USB app to be connected at one time, and it is often good practice on Android devices to not only shut off the DJI app but disconnect and reconnect the USB cable before turning on the DD app. That may help.

You can also set the maximum speed on the drone to a slower speed in the DD app to facilitate better pictures if you want.

I have been using that drone as well. I have better quality pictures when I slow down the flight speed. I work for a non-profit and we don’t have the money to upgrade everytime something shiny and new comes out so we have to find work arounds. I have not played with the manual settings but once and had very poor results.

I can’t connect my Phantom 3 4k with DD App. Can you guys show me how. Thank you in advance.

1 Like

What mobile device and operating system version?

What DroneDeploy version?

Please describe exactly what is happening in more detail.

I am using Sony Xperia 10 Plus on Android 9. DroneDeploy Version 4.1.0.

I can connect successfully with the DJI Go App. But nothing’s happening when I try to use the DroneDeploy app. It’s telling me to Connect Drone.

1 Like

Something to watch out for on android: when you connect the phone to the hand controller, android detects the new device and pops up a message asking which app to associate with the device and then asks “just once” or “always”. The first time I tried this (with the dji go app) I selected “always” and then I could not use any other apps with my phantom. I had to dig deep in the settings and clear that choice. Now I select “just once” when it pops up the message asking which app. Also, after you connect with an app (like dji go to calibrate the compass) you have to physically unplug the usb cable and replug it in before you can connect with a different app.

Oh and one bonus tip, when the android DD app loses connection in flight (even though the hand controller on my mavic is happily reporting active data) you can unplug and replug the usb in flight and sometimes that gets the app talking to the drone again.

I’ve run into a lot of glitchy things with the DD app on android, some things I have work arounds for, some not. Biggest problems lately: DD flew a whole battery but didn’t notice that the pictures were being taken, so the next battery it repeated the first section over again (and this time happily counted all the pictures.) The sd card had a whole flight of duplicate images. The next issue I’m struggling with on multi-battery missions is that sometimes nearly a whole row gets skipped at the point of the battery break. Somehow DD returns further into the mission than where it left off. And the android app lags at least several revisions behind the iOS app. Sadly if you really want to get the best out of a dji drone it seems like you are going to end up with an iOS device one way or another because of the app situation.