Unnecessary RTH


#1

I’m currently experimenting with DD during my 1 month trial. My main need is to periodically map my maple farm. I mapped the terrain which is around 86 acres. The height is only 170ft but I’m launching from the top of a hill.

The mapping starts out great, even if contact is temporarily lost, the drone continues on its mission. Soon after the first battery change, the drone RTH. No message or notification on the app, just the automatic RTH beep on the remote. I tried re-starting the mapping from the same point with a brand new battery with the same results. The max distance is not set and I also tried to set the max distance to a very big distance just to make sure. The drone is at the latest firmware and the latest no-fly zones are uploaded. I’m nowhere near any no-fly zones anyways. The DroneDeploy app is at the latest version and it does have internet access for the whole mission although the drone may lose contact from time to time.

Here’s my latest launch attempt:

I tried to go directly to way point #18 as you can see by the dotted line. Shortly after losing contact, the drone, apparently off-course, reappeared and the RTH beep started. The drone does not always reappear off-course however.

VERY IMPORTANT: I tried re-creating the same ‘mission’ in Litchi and it performs perfectly without any unnecessary RTH (even if contact is lost for several minutes). I did this several times. So what is happening in DD that is not happening in Litchi?

Since parts of my initial maps were imaged 2-3 times because of all the retries and some other parts were imaged 0 times, it created a very spotty and un-reliable map.

As is probably standard practice, somebody from sales (Jacob?) contacted me by email shortly after my first map to set up an appointment. I replied with my cell number and a few discussion topics including my inability to complete a map and also fact the there was a big gap between the free plan and the pro plan from a money standpoint and my occasional needs. Maybe dismissing me as a potential paying customer, he hasn’t got back to me after a week.

Thanks.


#2

The best place as a free customer is to get support here from DD and the community.

It’s weird that it is returning every time for you. Can you try running a similar waypoint mission in DJI go just to see if you get an rth? Dronedeploy is not triggering it, so I’m curious to see if it does it during a DJI go waypoint mission.


#3

I forgot to mention that I’m using a Phantom 4 Pro.

I really thought that, under the circumstances, this would qualify under ‘bugs and feedback’ so I’m at the right place?

Also as I wrote, I did what you asked but with Litchi, a 3rd party app as DroneDeploy without any problem. I never used DJI GO in waypoint mode, how does it behave when contact is lost?

Thanks.


#4

You might be able to specify what it does on disconnect.
DJI go uses similar waypoints which is why I asked how it behaved.


#5

Of course, in DJI Go there’s a setting to specify what to do in case of disconnect. The current setting is RTH. Why would this have an effect in DD and not in Litchi? Everywhere I read in the forums before posting here told me that in case of disconnect, DD would complete the mission and then RTH if still disconnected.


#6

So this isn’t the setting I’m referring to. I was wondering if there wAs a waypoint specific setting. Either way, it is odd it’s returning home. I wanted to rule out some setting or issue on the drone by trying djigo.


#7

I will give it a try (using DGI Go) tomorrow, it’s getting dark now. Again, I’m not sure about DGI Go’s behavior in waypoint mode if the signal is lost (which it will be) My base premise is the fact that if it works in Litchi, it should work in DD but it doesn’t. I can try Pix4D Capture but they don’t do polygons yet. I will update the thread tomorrow with those two tries.


#8

You’re flying pretty low over tall homogeneous trees. This may make it difficult to stitch.

If you are using an iPad, you might try DJI GS Pro and see how it responds.

You also might try the same flight plan at 400 feet with 80/80 overlaps and see how the increased altitude affects it.


#9

When you change batteries, are you rebooting the DD app or is it still running from the previous battery?


#10

As I mention, the height seems low but I’m launching from the top a a hill so the effective height is closer to 300-350’ for most of the run.

I found the stitching to be very good with what I was able to get. My problem is with the photo acquisition and not the stitching.


#11

I have to reboot the app sometime and sometimes not but the battery % is always accurate on the app.

I tried several time and my last attempt was made with a brand new 100% battery and directing the drone to a specific way point (see photo in the first post). The drone doesn’t even reach the way point and RTH while on its way there. I don’t have an ipad but again, maybe what I’m saying is irrelevant but I can replicate the same mission using litchi and the drone completes the mission without any problem.

It’s been raining here for almost 2 days so I haven’t had the chance to retry it. Just for kicks, I made a similar mission with pix4d capture to see what happens.

Is mentioning other software banned or frowned upon? I really don’t want to offend anyone, I just want to detail my troubleshooting process. For me, the second it works in another software using the same hardware in the same location, the hardware itself and the geography is eliminated as a potential cause but maybe I’m missing something.

Thanks.


#12

The reason I ask is I have had a similar issue after changing batteries, rebooting before continuing the mission seems to work every time. May be worth trying?


#13

Thanks. We’re looking into this to see if we’re doing something that could cause this for you.


#14

Hi @jflaplante,

Can you answer a few questions for me so my team can further investigate this issue?

  1. What DroneDeploy app version do you have installed?
  2. What is the make and model of the mobile device you’re using?
  3. Does the issue persist if you create a mission that is in a different location?

Keep me in the loop,
Christina


#15
  1. From what I can see in the settings, ‘Version Mobile 2.55.0 - 2.55.3’
  2. Galaxy Tab S2 with Android 7.0 installed.
  3. I don’t have easy access to another location. I’m only flying over my own land so far. I will try to verify with my neighbor if I can fly over his land. From a troubleshooting standpoint, I can see the relevance but again with the comparative testing using other software, it shouldn’t matter.

I’m still waiting on the rain to stock long enough, during the day, so I can do some more tests.

Thanks again for all your inputs.


#16

Thank you @jflaplante. My team will be investigating this issue and we’ll get back to you once we have more info to share.

If you’re able to fly other missions in a different location or with a different device without issue, please let me know immediately.

Thanks again,
Christina


#17

Hello again,

So today, the rain was gone and I was able to make some more tests. I just want to fly over my own land so I didn’t try to reproduce the mission somewhere else as someone suggested. I filmed my tablet’s screen (very low tech I know…) for each attempts if you have time to waste! Sorry for my french accent…

Test #1: New app version of Drone Deploy (2.56.1) dated 2017-09-08. Same result, the drone RTH before even reaching its first way point and starting taking pictures.

https://photos.app.goo.gl/ka20OIR9xj2A47Hz1

Test #2: Still in Drone Deploy, I deactivated the ‘collision avoidance’ option and got the same un-wanted RTH result.

https://photos.app.goo.gl/RMfUeMpm0Shii69r2

Test #3: I reproduced my perimeter with Pix4D capture. Since they don’t support polygons yet, I had to draw a little bit bigger to get everything but I kept the same altitude. So the farthest point was a little farther than the one in Drone Deploy. This time, like in Litchi, the mission completed without any RTH. This video ended up in portrait mode even if it was filmed in landscape. Sorry for that!

https://photos.app.goo.gl/8pHTRj5TNwoFGNNk2

So basically, the drone, sd card, remote, tablet and location are the same but only the software is different. We have two softwares that works (Litchi and Pix4dCapture) and one that doesn’t (DroneDeploy).

Just in case any DD DEVs are lurking here, without knowing anything about the DJI API, there’s must be some kind of flag like ‘LostContactRTH = false’ that is uploaded with the mission way points and parameters to the drone. Is it set to ‘LostContactRTH = true’ by any chance? Maybe it is completely un-related to the Drone losing contact also but something strange is happening.


#18

Thanks for the additional info @jflaplante. My team is currently looking into your issue and I hope we have an update to share with you soon.


#20

My 1 month trial is coming to an end next week. I was really hoping to complete at least one map during that period. Also, after reaching out to me to set up a phone meeting, the sales rep never called or emailed me following my reply. I would not be expecting anything if he wasn’t the one to initiate contact…


#21

Hi @jflaplante,

I sent you a private message requesting some info. Please get back to me at your earliest convenience. My team is still looking into the issue you reported and I currently do not have any updates to share on that front.

Cheers,
Christina