Unable to upload the photos

#1

Hello.

I took photos with DD and tried to upload them, but it said “Something went wrong attempting to upload your images. Contact support if this issue continues.”

I tried it again 1day after, but it says the same message.

How can I upload the photos?

#2

Try doing a smaller amount of photos, say 50 photos and see if that work.

If that still fails

Contact support@dronedeploy.com and send them a few photos so they can determine if the photos are properly geotagged with gps location.

#3

What browser are you using?

#4

hello, i am facing the same problem, have tried chrome, firefox, edge and nothing works. does anyone have a working solution?

#5

Please go through the questions that have been asked thus far and provide a little more info on your scenario.

#6

Are you using a trail version?

#7

i am using the free trial

#8

Has it expired? You only get 30 days trail. I think after it expires you cant upload. Its been awhile for me to remember.

#9

no, it cant be expired i just signed up for it

#10

Can you post 1 image here so we can look at the image exif data.

Also what drone are you using and what flight software (DD, DJI Go, Litchi, Pix4D, etc)?

How many photos are you trying to upload from your mission?

1 Like
#11

Free trial lasts only 14 days so it would be good to address this issue soon.
Regards,
Terry.

#12

Thanks for the correction on trial time.