"Unable to start mission"


#1

Drone Deploy,

I have been trying to map areas using drone deploy but i have been getting error messages as “Unable to start mission”.

I use a Phantom 4 Pro and my controller is connected to IPad Mini. All my devices are up to date on the software front.

Usually before a flight, i create a KML file of the area i am going to map through Google Earth and i attach the KML on to the drone deploy. The Drone Deploy application reads the map file successfully and the flight plan is created.

I proceed to the respective area and set up my drone to map the site. I turn on the drone and the controller, i open DJI app and calibrate the compass and when all is set. I go ahead and close the DJI app and open the Drone Deploy app, the drone gets connected to the app. I open my flight plan and initialize the flight. All the parameters are check listed in green. Now i command the drone to take off yet my screen reads a message on the bottom stating “Drone Initializing…” and after few seconds another message reads on the bottom stating “Unable to start mission”. Even if i repeat the same process, the result is the same “unable to start mission”.
I thought this error is due to me using Offline base map so i also tried to map the area with the internet connected to my IPad and drone deploy yet the same problem occurs.

Mean while, i decided to create a flight plan of the area i want to map in my IPad from the job site while connected to the internet and carry out the same steps and fortunately the drone takes off and starts capturing images and completes the flight successfully.

So basically i am not able to proceed with my flight if i upload a KML/SHP file on to drone deploy while creating a flight plan.

I will not be able to create a precise flight plan manually from my IPad everytime. I prefer creating a pre-flight plan through Google Earth.

Advise me on how to resolve this issue. Waiting for your reply.

Thankyou.


#2

Hi @eagleeyeug,

Thanks for swinging by the forum and sharing your latest flight experience with us. I’m sorry to hear you weren’t able to execute your flight with KML/SHP file planning. I’m curious if you had the chance to power cycle your drone, controller, and device to see if that helped to initiate the mission? We recommend doing so to clear out any conflicts and reset the app.

It would be great if you could try to plan another KML/SHP flight (perhaps over your neighborhood or somewhere easily accessible) and see if you encounter the same issue again. We can dive deeper into this if you’re able to reproduce it more than once. Keep us updated!

Thank you,
Stephanie


#3

I replied to a similar post a few days ago about the same issue as this. I had not realized at the time that it may have been a result of using a Google Earth kml file that I uploaded. I have had the same results as eagleeyeug. I have done the power cycle routine and made sure that all the files/apps I had were up to date. I even changed the device I was using to connect from an LG G6 (unsupported) to a Galaxy S7 and had the same results. I was also able to fly if I created the flight plan manually in the field. I do however receive kml files from clients and it is far easier to be able to just upload what they send me than it is to have to create manual flight plans onsite.

Thank You


#4

Hello Stephanie,

Thankyou for your suggestions.

I did power cycle my drone, controller and also reset the app every time yet the result was the same “unable to start mission”.

I planned a new KML flight plan and tried it online as well as offline but the result is the same “unable to start the mission”.

I also updated the software of my drone again just to be sure but no use. All My devices are up to date (Drone,Controller, IPad, DJI Go app, Drone deploy app). The same error message occurs.

Unless the drone deploy has a bug to be fixed with the new DJI software for Phantom 4 Pro. Because it worked very well on the previous software version. Am not sure, just a thought.

Please advice me on this and looking forward to the solutions asap. I have projects lined up.

Thank you.


#5

Stephanie,

I now also tried mapping with the previous DJI software. It dint work, same result occurred.

Hope you can provide me with the solution soon.

Thank you.


#6

Hi all,

We’re escalating this issue to DJI for further review and investigation. Unfortunately, I do not know how long this will take but I will be sure to update this thread as soon as I have info to share.

Cheers,
Christina


#7

Hi,

i am facing the same problem. Any updates?


#8

Hi @rohit_ranjan,

Can you add some additional info about your setup?

  1. When did this issue first occur?
  2. What is the make and model of your drone? Is it on the latest firmware?
  3. What is the make and model of your mobile device?
  4. What DJI Go app and DroneDeploy app do you have installed? I suggest double-checking the iTunes App Store and Google Play Store to verify you have the latest versions as well.

Keep me posted,
Christina


#9

i didn’t check that a new update was there for drone deploy in the store…i have updated it now,will try out tomorrow morning. I will let you know if the problem continues and thanks for immediate reply.


#10

Hello
I have the same problem. The Phantom 4 Pro has the firmware and application updated, but when I make a flight plan on the computer and I will run the flight does not start. When I make the flight plan on time, it works.
Every time an different error appears: invalid fligth logs, error camera focus, check gps filed, invallid flight mode supplied undefined.
I tested different smartphones and the problem continues.
I hope you correct the problem because it is affecting the works very much
Thanks
Murillo H.


#11

Hi @MurilloH1,

I’m sorry but I am not sure I quite understand your issue. What do you mean by “make the flight plan on time”? To clarify, you cannot run a flight plan on a desktop. Your supported drone must be connected to our mobile app on a supported mobile device for the flight plan to run.

For your reference, here are lists of our Supported Drones and Supported Devices (Mobile and Tablet).

Keep me posted,
Christina


#12

eagle i’m getting the same problem and i was really wondering if you have ruled it out? please come with updates especially if you found a solution. Christina deeply appreciating your help, can i ask questions in case i would have some? thanks!


#13

Hi @Smuctingly,

Of course you’re welcome to ask questions! If the questions you have are unrelated to this topic, I kindly ask that you create a new topic for yourself. To do this, go to the home page of our forum, and in the top right corner you should see a button that says “+ New Topic”.

Cheers,
Christina


#14

I’ve not had for a good few months (used to do it all the time), but I experienced the ‘Unable to start mission’ a couple of days ago. I believe I am on latest firmware and software throughout.

First the camera failed to initialize and then when I tried again and got past that to the ‘take off’ button, it failed. Ran it again and it worked.