Unable to Start Mission - Phantom 4


#1

Summary of Issue:

Attempting to fly a plan and getting “Unable to start mission”, with no hint towards the potential root cause. All items in the check list are green and drone gets no error while initialising.

This is a location that I had flown a few weeks before with a Phantom 4 Pro. After this error was shown, I was able to manually fly the drone without issue using DJI Go 4. After the manual flight, I was still getting the same error when I tried again to fly the plan. The same drone and iPad flew a different mission at a different location the day before.

The only thing that I can think could be the root cause is that it was a very hazy, overcast day and maybe the GPS signals weren’t strong enough. However, it would have been good to have a message from the app that indicated a potential root cause for why the mission could not be started.

Date Issue Began:

Dec 7, 2017

Drone Model:

Phantom 4

Mobile Device Model and OS version:

iPad 2017, iOS 10.3.3 (will update to 11.2)


#2

Hi @EdwardCaulfield,

Can you share the name of the flight plan as well as the email address associated with your DroneDeploy account?

Thanks,
Christina


#3

Hello Christina,

Thank you very much for following up on my topic. My email address for the account is edward.caulfield@gmx.ch and the plan is called “Auslikon”, created on December 4th. The plan I successfully flew at the same location several weeks ago is called “Auslikon Full Property” from Nov 15th.


#4

Hi @EdwardCaulfield,

Thanks for getting back to me. I’ve escalated the info to my team for investigation. Can you let me know if this issue has popped up again recently?

Cheers,
Christina


#6

Hi @EdwardCaulfield,

It’s likely that your drone was just in a bad state since you’re able to fly normally without issue. Did you restart all of your DJI devices and mobile device when you received this error message?

Cheers,
Christina


#7

I don’t think you statement is correct. I cycled power on the drone and killed the DroneDeploy, both actions twice, app before I did the manual flight. Additionally, I cycled power on the drone and tried DroneDeploy again after I was finished with the manual flight. The result was always the same.

Best Regards,

Edward


#8

Hi Edward,

To verify, you restarted your drone, remote, and closed out both the DJI Go and DroneDeploy apps? Can you also verify the GPS signal at the time?

Thanks,
Christina


#9

Hello Christina,

Than you for your follow up. The sequence of steps were:

  1. Start drone and Drone Deploy app

  2. Attempt to fly plan, failed after all checklist items are green

  3. Power off drone, kill Drone Deploy app, make sure DJI Go wasn’t running - which it wasn’t.

  4. Power on drone, start Drone Deploy, attempt to fly plan, failed

  5. Power off drone again, kill Drone Deploy app, wait two minutes

  6. Power on drone, start Drone Deploy, attempt to fly plan, failed

  7. Kill Drone Deploy, Start DJI Go, Fly manually

  8. Kill DJI Go, start Drone Deploy, attempt to fly plan, failed

  9. Power off drone, kill Drone Deploy, wait one minute

  10. Power on drone, start Drone Deploy, attempt to fly plan, failed

In all cases Drone Deploy failed even though all pre-flight checklist items were green.
At the time, I did not think to check the number of GPS satellites registered. On the way home I checked the Navigation system in my auto and it only saw five, sometimes six, satellites.

As mentioned in my original message, I suspect the overcast day was the root cause of the failure. However, it would have been helpful to either have a more complete diagnostic message or the option of turning on a debugging mode that would provide detailed information on the Apps progress.

Best Regards,

Edward


#10

The same exact situation here…“Unable to Start Mission.” Connected to drone and all green checks. I was able to fly with the DJGO app, but no success with DD. Tried two different P4P drones and the same result. Hadn’t had a problem before the last DD app update. All firmwares up-to-date. The weather condition was overcast and temperature in the mid-30’s.


#11

Thank you for providing the steps @EdwardCaulfield. I’ve forwarded them to my team for further investigation.

@GeoTech, can you share the email address associated with your DroneDeploy account and the name of the affected flight plan(s)?


#12

Hi @EdwardCaulfield,

Can you verify that all your software for your drone and remote control is up to date? We also just rolled out a new DroneDeploy app version (2.63) so I suggest making sure you have that installed as well.

Can you also verify if this issue occurs with other drones?

Keep me posted,
Christina


#13

dnorgord@geotechmap.org
McLain\McLain Lane 1
McLain\McLain Lane 2


#14

I think the problem lies with the Multiple Mission setting in the DJIGO app. I believe that after the last app update, or perhaps, the firmware update, it defaulted back to it’s original state. I haven’t tried flying again after I noticed that the multi mission setting was not set, I bet that’s the issue. Sorry for the false alarm if that is the case.


#15

Hello Christina,

I am currently at 2.62.0 and taking a look at the App Store see a new download available as of today. When I get a chance to fly again, I will try the flight plan again and also verify the drone software / firmware versions.

Best Regards,

Edward


#16

Regarding the Multiple Mission setting on DJI GO, I wouldn’t expect that this setting could impact Drone Deploy unless DJI GO was running at the same time. Or am I missing some connection between the two apps?


#17

For whatever reason the multi mission setting in DJI GO does impact DD. It happened to me before. I didn’t realize that the setting had reset itself, probably (i don’t know for sure) because of a recent update. I’m using an ipad 4 mini.

Edward, have you tried that setting?


#18

I have never experimented with DJI GO until I had to fly manually. What does the Multi Mission setting do? I am not finding it in DJI GO.

Even if this is the root cause, I think DD should have an error message that is sufficiently detailed to give us a direction on where to start looking for a resolution.

Personally, I still suspect that this is an issue with the heavily overcast weather, but I’ll experiment…


#19

The setting is actually called “Multiple Flight Modes” and you can enable it via the Main Controller Settings in the DJI GO app. Check this thread out: https://phantompilots.com/threads/how-to-enable-multiple-flight-modes.100241/

If that doesn’t do the trick, then it just may be due to the cloud cover. I too was flying on a low overcast day.


#20

Hi @GeoTech,

Unfortunately, we weren’t able to locate any debug logs with your maps that would help us with our investigation. Can you try the following?

  1. Reproduce the error
  2. Leave the DroneDeploy app open for at least 5-10 minutes when connected to the internet to give the debug logs a chance to upload.

If you have any info on when the error occurred, such as date and time, that would also be helpful as well.

Cheers,
Christina


#21

Christina,

The time range was approximately 1130-1230 CST. Unfortunately, I don’t know when I will be able to fly again since the weather will not be favorable for the foreseeable future (Living in Wisconsin).

I’m betting that the problem was with the Multiple Flight Modes option not being set in the DJI GO app. Somehow it reset itself during a recent update. I’m hoping that Edward might get a chance to test this since his setup is very similar to mine. Although we both had overcast conditions, the GPS reading was still fairly strong when I was flying, so I don’t see that as the culprit.