Un focused - blurry - pictures from Phantom 4 Pro

I’ve used Drone Deploy for some years now flying mostly DJI Mavic’s but now got my hands on a Phantom 4 Pro.
Kept using DD for land survey missions but have run into problems. Pictures are not focused - neither straight downs nor nadir ones taken during a 3D-mission. Comparing with similar photos taken with same drone from Go4-app shows a significant difference. Have been flying on 50 and 80 meters.
I’ve tried both manual setting from the Go4-app and the fully automatic from DD but nothing helps. Anyone know the reason? I’m using a Samsung Activetab 8" with Android 7.1.1 for the control. Also tried to set up one of the quick buttons on back of control for focusing but no success.
I don’t dare to take off with the Go4-app and then switch in mid air to DD as it seems to risky to me, so all settings done while on ground.
Any help is appreciated! /Theo

1 Like

Hi Anders,

When using DD, I take-off and ascend to mission height while using GO. I hover over a high contrast area near me and set focus. Then completely close out of GO, start DD, load mission and start. I never have focus issues using this method with the P4P.

Switching control apps in flight when the drone is clearly in your vision and locked up with a gps hold is trivial and safe. I do recommend you know how to recognize and be able to control the drone in ATTI mode though in case for whatever reason gps lock is interrupted and you are left flying in ATTI mode completely by VLOS. Many operators have never practiced this.

Thanks a lot Dave
I’ve red about the method you’re suggesting and maybe you convinced me to try it. My main concern is the feeling of not being in control while swapping apps in mid flight. As long as I’m able to control my drone with the remote it shouldn’t be a problem, I’ve had many hours of non GPS-controlled flight.
But unfortunately I’ve also had experiences where I’ve had no control what so ever through the remote while running Drone Deploy missions - and that is not a nice experience!
Anyway I’ll give it a go, because as is - all my pictures are crap!

Would be very nice to know though, what is the reason for this issue with no focusing regardless of settings in advance?
/Anders Theo

It’s a funny thing how we think about our control over the drone. The only thing DroneDeploy is doing is complicating a matter of native communication. DJI protocol is always running in the background and we sometimes don’t remember than the RC is our actual interface to the drone so no matter what happens to an app or mobile device you should still maintain complete control. What these apps are doing is providing autonomous flight which is actually removing realtime control from us. Closing down the DroneDeploy app was our default way of doing daisy chaining before the new DroneDeploy UI.

Has the blurry condition always existed with the drone since you “just” started using it?

Michael, I think I get your message, I simply need to be more confident and just shut down whatever app I’m using if/when it “f…s up” and rely on the pure radio signal still transmitting. :wink:
I’ve haven’t had any issues with blurry pictures using DD for my Mavic Pro and the Pro 2. It all started when trying DD for the PH4Pro I’m now using for my employer.
The officer who’s used it previously never ran DroneDeploy but rather Pix4D or MapsMadeEasy which both performed well when it comes to focusing. But I don’t fancy any of them since I’m planning many missions in advance on maps drawing polygons and exporting kml-files which is easy in DroneDeploy.
Best Regards/Anders Theo

Correct. The live video and telemetry provided in various degrees by the different apps are great and enhance situational awareness and thus control. But, the RC is still the means by which the aircraft is controlled. And being comfortable shutting down apps while maintaining traditional vlos control will add to your overall operational expertise. I can tell you will jump in and make it happen.

It would be nice if all apps magically did everything we want them to do without hiccups. But that day isn’t here yet.

2 Likes

Exactly as @Dave says, the RC is what maintains control of the drone.

The only way I’ve been able to take a picture IN focus for three years is by taking off in Go4, setting up, closing down and switching to DD. In the early years I was using Android, which was a bit more fiddly (having to clear the app’s cache) and was because of this after each battery change, I got fed up and invested in iOS. I still have to switch, but it’s now a case of being without visual on my screen for a matter of 3-4 seconds rather than a minute. Perfectly safe. :slight_smile:

Exactly period this has been a problem with the mavics for infinity, but this is specifically about the Phantom 4 Pros. I’m trying to figure out if this is a global case that is just popped up or if it’s isolated and maybe a glitch. My problem is that I use an iPad Mini so I can’t really tell on the screen how in focus the image is period I will need to try to hook up a full size iPad to verify beforehand.

1 Like

Yes. Notwithstanding the old Mavic issue may now have potentially become a new P4 issue, Dave and I were providing comfort to Theo, in that it’s okay to switch between apps.

1 Like

Dave and MichaelL, thanks a lot for sharing your knowledge!
Today I’ve dared to use the method you suggested and it all went well - almost…
After finishing the first battery and by that turning off the drone it shifted back to default settings again and I tried to connect to the drone with Go4-app again. Well, at first it wouldn’t let me and I had the feeling I would be forced to shut down DroneDeploy to make it work. But by doing that I thought I’d also reset the mission I was in the middle of.
After a few attempts it suddenly worked and I could raise up to my 80meters and set focus and exposure in the Go4-app. Then shut down that app and returned to the already running mission in DroneDeploy. It was still asking me to either reset or resume so I choose to resume and to my surprise it worked.
I’ll include a link below if any of you are interested taking a look at some samples. I certainly learned a lesson through this and I’m surprised I never had this issue before with my Mavics!
Tomorrow I’ll continue by flying a mission in our little town Leksand and I feel a lot more confident now that I’ll be able to get those sharp pictures I’d love to show my employer later. Thanks a lot for your advice!
And one thing more - wouldn’t i t be great to be able to monitor all those camera settings directly in the Drone Deploy app?
All the best, Theo
Google drive folder with some samples and file info from screenshots

Yes, it’s annoying. As Michael pointed out, my experience only comes from using my Mavic. You have to take off in Go4 and set up the camera after each battery change. After 3 years, I’ve just got used to the fact that I have to do it. Just normal to me now.

I think where you got stuck, or maybe not, I don’t know, was if you are using Android, you have to pull the cable and go to app preferences to clear the cache before being able to switch between the apps.

After the drone lands for the first battery change, I force DD to close, do the swap, set up in Go4 at altitude again, force close and resume in DD. It works really, really well, albeit you shouldn’t be having to do it with the Phantom. The only pig of it, is that you lose a few % of battery having to mess about with it. More so when using Android.

Absolutely it would. I don’t think we need the ability to tinker with them, but just a readout would be great. Glad you’ve got a path!

Glad it worked out. With adjustable focus cameras, it can be hit and miss depending on when the automation taps focus. Consistent results have been much better for me doing it myself…in both of the control apps I use.

It is certainly doable if DD wanted to. Map Pilot devs were resistant too, but finally broke down and included camera controls. So much easier to do it all in one app! :wink:

1 Like

Thanks James, more good advice, that’s great!
Yes, I’ve been using Android up until now but from yesterday I have swapped to use my colleagues I-pad.
It seems a challenge big enough for me right now, to just have to stop and change app in flight. Having to unplug and force stop doesn’t sound like a job for me with cold hands and currently running the drone on only two batteries!
I was just wondering about that detail you’re describing - “force to close”, what exactly does that mean? You are not just shutting down the app as normal but rather going into the settings and really force it to stop?
Also I must express my joy and thankfulness to all of you who have answered my call for assistance in this issue. The way you all have responded and the “tone” you are using is far more nice and polite than in any forum I’ve visited from Swedish sources. I don’t know whats wrong with us in Sweden, but we seem to focus on our colleagues weaknesses and mistakes instead of supporting and cheering each other. Thank you all!

3 Likes

Hi Theo.

I understand exactly where you are coming from. All of your complaints and fears I have previously experienced and lived with, but am now at a place whereby I can rest easy each time I fly a DD mission.

In Android it’s a pig. You need to first set up the camera in Go4. Once ready, go to the home screen and then to the list of apps running in the background. Go4 will be the first one there. Close it.

Next, pull one end of the usb cable out. It used to be a little disconcerting, but you just learn to trust it. The RC remains connected to the drone, so it’s not going anywhere.

Next you need to wipe Android’s USB default app for when a device connected. If you don’t, it won’t allow you to connect to the RC/drone in DD. This is where you were struggling before I think. Follow these directions. https://forum.dji.com/forum.php?mod=viewthread&tid=75403

It’s dead easy, but with doing this and setting up the camera for manual focus (and maybe exposure etc), it takes time. Battery % is gold dust and I used to lose 10-15% on each battery change. Not to mention the wear and tear on the USB ports.

Reconnect the cable and open up DD. Drone connected. Make sure the manual toggles are set to Go4 and start mission. After that battery, you need to pull the cable and clear the default again before going back to Go4 to set up the manual camera for the next section of DD mission.

A royal pain in the arse and the main reason I switched to iOS. About 2.5 years ago?

For iOS, take off in Go4 and set up as before, leaving the camera settings in ‘manual’. Go to Home screen and bring up the list of minimised apps. Close Go4 (by swiping up) and go back to Home screen. I generally leave it 2-3 seconds before opening DD, as sometimes and maybe it’s just me, ‘drone doesn’t connect’ if I switch too quickly. I think that was a year ago, but I’ve not had the problem for a while so I think the DD app or maybe iOS has fixed the problem.

Open DD and ‘drone connected’.

The reason you shouldn’t have both apps open in iOS is because each of them are resources hungry. DD V4 is bad enough on its own, so definitely don’t attempt running Go4 at the same time, albeit minimised. Some have suggested crashes or drone failure has been caused by the two apps runn8ng simultaneously, so just best not to chance it. Only have one app running.

If it wasn’t for the help that others have shown me here in the past, I’d still be scratching my head about what pictures I should be taking for DD to process. My time on site to carry out the same task has easily halved over the past couple of years, thanks to likes of @MichaelL and @Dave, as well as a few others.

2 Likes