Trying to sync pc made mission on dd with iPad dd

I can not for the life of me get any missions created online with dd to sync up…

It says that it synced on the PCs side but nothing shows up on the iPad, what do you think I am missing here?

Running the latest fw and dd app… Could it be an iOS update that needs to be performed?

Thanks in advance.

Are you connecting to your drone and then checking for the plans?

I tried using my iPhone 6 Plus next. I had the drone connected and this time I was able to press the back button and one of the of flights showed up… Then I tried checking the data explorer which showed that one synced mission.

Now dd will not let me back to view said mission, it just zooms to my iPhone gps location with no flight plan…

I’ll try some other stuff tomorrow evening and post if anything changes.

The data explorer should only show maps that you have made, not plans that have been synced.

Hi, sorry for the super late reply, I am having another issue that I cannot figure out…

When I plan a mission online and try to run the mission in the field (no network coverage), none of the base map imagery is displayed. Looking back through the forums I see that this was a late addition with the android version, is this working for anyone on ios products yet?

Or am I being silly again and missing something simple?


If you want to have your base layer map tiles cached, you can preplan on the desktop version of dronedeploy and then it should sync to your phone.

When I sync from desktop to the phone, none of the basemap tiles show up, I can see my planned mission but just only in front of a white background…

I was able to sync a pc made mission today. The camera doesn’t show up correctly in the dashboard however. It says DJI2 rather than DJIX5 like the missions that I create in the ipad show. I’m not sure if this affects the performance but is causes concern.

On another note: (I also mentioned this in another post) neither my PC made mission or the app created missions are giving me correct overlap.

The desktop planning still says DJI2, should be fine. We are going to fix this in the near future when we overhaul planning.

I think we have an issue with the X5 and overlap. A lot of users have reported this. We are looking into it.