Tons of issues. Was told by Chat to report here

Alright, where to start? I have a P3A, was using firmware on the previous DroneDeploy. FW was 1.4.001, Galaxy Note 8 running 4.4.2. I flew one mission with a reported camera error and a suggestion to update to FW, but it completed the mission although it never auto uploaded. I manually uploaded and in the end, all was good. I the upgraded to the beta and it errored out on connect. I never had the chance to chase this any more.

Now 1.3.2 showed up along with my biggest desire - to setup at home on the computer. This is where it went downhill! At best, I can draw a kind of a box in the area I want to map. Once I click the last “link” or whatever the last data point was referred to as, that’s it. I can’t fill any or see the altitude auto fill, nor the time, Area and windspeed look somewhat accurate. I fiddled with every setting on the screen and the best I can do is load it on a simcopter (what the hell is that?? maybe a placeholder when a real drone isn’t attached?) and then the P3 is red-exxed and non-usable. The advanced box lets me put in an imaginary altitude, but it never transfers. (this is with firefox and chrome, IE won’t go past the logon screen - tells me some site is unavailable and that I can’t type). It somehow managed to sync with my Note8, but I can’t pull the data up anywhere. Only 3 plans show up in data explorer and these are the 2 demos and my first attempt. There are no arrows on the main screens or any other means to select anything. You’ll get this right in time, but at the moment, it’s a mess!

D D 1.3.2
P3a 1.05.0011 beta
Galaxy note 8 4.4.2
I tried to fly just now and it only got worse. Crashes, 1 time I got to see a plot screen but it crashed. Endless calculating plan screens. I ran the battery down by 2 bars in the time it took rebooting, forcing stops, killing apps, dumping cache,and everything I could throw at this thing to attempt to make it work. I finally laid out a small plot then made the mistake of attmpting to lower the altitude and that resulted in a frozen map screen.

Thanks for reporting this issue, we have a fix in the works for the Play store - in the mean time, you can use the APK listed here: Problem with v1.3.2 APK [resolved]