Test photo failed, then worked 3 times, then failed..and failed

I know… there are several threads on this issue. I bought a new Mavic 2 Pro. When I started the DroneDeploy app today, and began the flight, it went through the checks and stopped on the test photo…which failed. I retried and it worked. This repeated the next to flights (failing at first but working on a retry)

However on the the 4th flight with a new SD card, the “photo check” would not work. I tried the 3rd party camera button and it “worked” but took no images and showed no camera view. I switched the button off, turned the app on and off, formatted the card in the DJI app and reset the camera. I reformatted the previous card …and about 3 hours later - trying every possibility including reinstalling the app. I tried a flight without checking the photo test (flying anyways), it flew and appeared to take images …but I got no images.

Any suggestions? could it have something to do with setting my phone to the MTP or allowing debugging on my Huawei Plus 10?

I do not see your device on the DroneDeploy list of supported devices at


Could this be the problem?


Could be… I had to buy a new device (the Huawei Plus 10) that would work with the Mavic Pro 2 (that I couldn’t afford) since it was not supported. I certainly cannot afford to buy another one now. There must be another possibility? I’d say that most people do not own devices on this limited list.

I never had a problem with my previous Mavic Pro (and previous P9 phone). DroneDeploy did work OK at first (albeit with retry’s.) I’ve got to finish this job tomorrow, but its not worth springing for another device. I guess I’ll need to do it manually with the DJI go app.

My Mavic Pro 2 is fussy also. When mine does this I pop the SD card out and push firmly back in. Usually works fine 2nd time. Not sure if specific type of card does this but it works after doing above.